(late 2013) rMBP upscaled resolution

Discussion in 'MacBook Pro' started by airlied, Nov 22, 2016.

?

have you experienced UI lag of macOS Sierra at upscaled mode?

  1. Yes, very

    33.3%
  2. sort of

    0 vote(s)
    0.0%
  3. No, Smooth like my girlfriend

    66.7%
  4. No retina display :-(

    0 vote(s)
    0.0%
  1. airlied macrumors regular

    airlied

    Joined:
    Jul 8, 2011
    #1
    Ive got a late 2013 high-end (at the time) 15' macbook pro. Now it's on macOS sierra

    I use native resolution which mimics 1440*900 resolution but everything is just too big, I tried upscaled (1680*1050) about a day (with a 2560*1080 monitor hooked up) it looks fantastic and the size of the UIs are perfect for 15' display.

    But just after few hours the UI becomes lag (or no longer smooth), especially in Mission control, swiping between desktops and the exposé. I have to reboot the laptop to get the fluency back. I usually have chrome open with about 10 tabs, and PDF expert open with 50+ PDFs.

    Would you please tell me what causes this UI lags? is it because macos didn't do well about rendering the UI or just because my laptop (GT750M) is too old to deal with these *modern OS*? Just wondering if this is a common phenomenon so we can count on apple fixing this in the future or it means I need a new laptop.

    Thanks.
     
  2. ah- macrumors member

    Joined:
    May 7, 2010
    #2
    I'm using that exact laptop with the same resolution and don't see any problems. No change in performance over time either.
     
  3. airlied thread starter macrumors regular

    airlied

    Joined:
    Jul 8, 2011
    #3
    do you hook up a external monitor?
     
  4. ah- macrumors member

    Joined:
    May 7, 2010
    #4
    No, just using the internal display.
     
  5. aevan macrumors 68000

    aevan

    Joined:
    Feb 5, 2015
    Location:
    Serbia
    #5
    I use that resolution and have a 1080p monitor plugged in, no lag whatsoever on my 2013 Mbp (high end).
     

Share This Page