MacBook Pro failure or SSD failure?

Discussion in 'MacBook Pro' started by aidan2901, Jan 10, 2019.

  1. aidan2901 macrumors newbie

    Joined:
    Jan 10, 2019
    #1
    Hi,

    The other day I upgraded my MacBook Pro 2011 (with an SSD) from Yosemite to High Sierra, it rendered it unusable. I attempted to do a clean install but it kept falling or stopping.

    I've now reinstalled Snow Leopard from the DVD that came with the MacBook (this took 17hrs). Again it's entirely unusable taking almost one minute to close simple applications such as system preferences, almost 40 seconds to simply navigate around in to different files and folders in Finder.

    Prior to all this my MacBook was running fine on Yosemite and I didn't have any delays or sluggish performance. I upgraded as I was a little behind on keeping the software up to date.

    Is this a signal that my MacBook is on the way out or my SSD is now faulty? I am struggling to understand what the issue may be given it was fine before I did any upgrades/changes.

    I appreciate any help in advance.

    Aidan
     
  2. th0masp macrumors regular

    Joined:
    Mar 16, 2015
    Location:
    germany
    #2
    This sounds really weird. Have you checked the Console for error messages?

    I recall experiencing really unbearably slow disk access only when I had damaged sectors on my old (spinning) system disk.

    For what it's worth I am typing this from a late 2011 MBP with a Samsung 840 pro SSD installed. It's always been zippy with performance you'd expect from an SSD-equipped device.
     
  3. aidan2901 thread starter macrumors newbie

    Joined:
    Jan 10, 2019
    #3
    Before I installed it I did a disk check via disk utility on the bootable USB (when I attempted Yosemite) and again on the DVD installer for Snow Leopard. Each time it came back fine, but I noticed when I was erasing the disk it couldn't seem to get rid of the recovery partition and when viewing the SSD in disk utility after it was erased it still showed 2 files and 3 folders. I resorted to erasing the drive to exfat and then back to Mac OS extended journaled before re-attempting the install. I thought by doing that I stand a better chance of a clean wipe.

    I've reset the SMC and the NVRAM and still unbearably slow. When I first got the SSD I installed Yosemite on it (can't remember how long it took) but it revolutionised the MacBook, and up until I tried upgrading to High Sierra it was performing impeccably without any lag or delay.

    I can't decide if I've been really unlucky and the logic board or something in it has become faulty during the upgrades/reinstalls, or if something is caught in some temporary memory somewhere on the board causing it or if the SSD has become faulty during all of this. I'm tempted to buy a new SSD and see if that resolves it but I'm not convinced it is that at the moment. It really is a strange one..
     
  4. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
  5. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #5
    Like the post above mine suggests, this is very typical indication of a failing SATA cable. They're inexpensive and easy to replace.
     
  6. Fishrrman macrumors Pentium

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    A way to verify "the cable issue":
    (yes, I realize this is some work)

    1. Take the SSD OUT OF the MBP
    2. Connect it via USB (even USB2)
    3. Try booting with the externally-connected SSD
    4. Does the bootup go much smoother?
    5. If so, that would indicate a worn/faulty internal ribbon cable.
     
  7. aidan2901 thread starter macrumors newbie

    Joined:
    Jan 10, 2019
    #7
    Good shout on the sata cable. I've got one ordered, keeping my fingers crossed that sorts it. I had the Genius Bar do a diagnostic check and everything came back fine so lends itself to the cable.

    Hopefully that sorts it! Thanks!
    --- Post Merged, Jan 11, 2019 ---
    Will give this a go tonight and report back, thank you!
    --- Post Merged, Jan 11, 2019 ---
    Just tried this and it works perfectly now so it must be the cable, grest advice thank you. Perhaps this is why it took so long to install the OS as well?

    I have a new cable coming tomorrow. Fingers crossed that sorts it.
     
  8. aidan2901 thread starter macrumors newbie

    Joined:
    Jan 10, 2019
    #8
    Just as an update and for anyone else who may have the same problem of very slow performance of incredibly slow OS install times, the fix of changing the SATA cable worked. Very cheap as well as quick and easy following a guide.

    Thanks everyone for your help!
     

Share This Page