macOS 10.12 Sierra Unsupported Macs Thread

Discussion in 'macOS Sierra (10.12)' started by redheeler, Jun 13, 2016.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. jackoverfull macrumors member

    jackoverfull

    Joined:
    Dec 3, 2008
    Location:
    Berlin, Germany
    #5251
    Just checked on my High Sierra (also unsupported) machine and Safari 12 is not coming up there either.

    I'm starting to wonder if I'm not getting it because I don't have a Mac that officially qualifies for Sierra/High Sierra.
     
  2. frankalpha88 macrumors newbie

    Joined:
    Oct 21, 2018
    #5252
    Hi, all.

    Has anyone found a solution for the following problem that I am currently having.
    Here is my story.

    - Imac 9,1
    - Updated to Sierra using Sierra Patcher from dosdude1.com
    - All works find except the following: iTunes not no longer sees the connection to iPhone
    - I know the USB cable is working as iPhoto app is working with a connected iPhone
    - Trying to figure out how to connect iPhone with iTunes (latest version of iTunes)

    Any solution for this issue is greatly appreciated.

    Plus, the brightness is always set to minimum upon startup...any fix for that would be helpful as well.

    Thanks.
     
  3. TrixxY macrumors newbie

    TrixxY

    Joined:
    Oct 22, 2018
    #5253
    Hi there... I'm not really new to Macs, since I own a late 2011 iMac 27"... unfortunately I have lost all my comuting knowledge as I didn't have to deal with it, due to the Mac ;)

    Nevertheless, my boy, 9years old, needs a laptop for school, and so I thought it would be a good idea to buy the cheapest Mac Book Pro I could find and ended up with the Mac Book Pro 15" aluminium body Core 2 Duo/4GB RAM/X1600 A1211 (should be a MacBook Pro 2,2).

    I'm trying to install Sierra on that machine with no success, I have dowloaded both files, patcher tool and Sierra, unpacked Sierra (twice?), formatted the USB stick (SanDisk 64GB USB3.0). Startet terminal, tried to disable SIP(is this activated on Lion?) without scuccess (command not known?). Run the patch tool and created the USB drive as described...Reboted and tried to boot from the USb stick (it shows up in the boot menu). First it looks like it starts booting from the stick, then just boots into Lion on the HDD.
    So I had the crazy idea that I should format the HDD ;/... so I'm writung you from the boot menu Safari.

    Can anyone guide me to my fault, did I miss a step?
    Maybe it's just a little thing I oversaw?
    Otherwise I'll have to reinstall Lion via wifi...

    Thank you very much, best regards from black forest, south germany
     
  4. mlmacml macrumors newbie

    Joined:
    Oct 22, 2018
    #5254
    hi! to install on macbook 2,1 where do i get the official sierra OS? It's not available in mac app store. i'm running SL right now,
    macpostfactor doesn't support pirated copies, right?
     
  5. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #5255
    Try reading post #5192 of this thread, this download issue has been covered many times.
     
  6. Lubidubi macrumors newbie

    Joined:
    Apr 16, 2015
    #5256
    I do have the same problem. Did you find a solution?
     
  7. mohair macrumors newbie

    Joined:
    Nov 6, 2018
    Location:
    EGYPT
    #5257
    Hello, I am running Sierra on MacBook Air mid2009 and its working fine except the App Store which always asking for Apple ID and whenever I enter it it says your device can't be verified although my Apple ID is working fine with iTunes and iCloud Drive .
    any help will be appreciated
     
  8. aquitemcaqui, Nov 8, 2018
    Last edited: Nov 9, 2018

    aquitemcaqui macrumors newbie

    aquitemcaqui

    Joined:
    Nov 8, 2018
    Location:
    Brazil
    #5258
    Be aware that Security Update 2018-005 10.12.6 may bug your Sierra patch install on iMac 9,1.

    You may loose screen control and/or USB.

    It is necessary to reinstall all patches, force cache rebuild with the post install tool, and install the backlight control patch after logon.

    Cheers
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page