macOS 10.14 Mojave on Unsupported Macs Thread

Discussion in 'macOS Mojave (10.14)' started by dosdude1, Jun 4, 2018.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. flygbuss macrumors regular

    flygbuss

    Joined:
    Jul 22, 2018
    Location:
    Stockholm, Sweden
    #11451
    Don't you have an empty hard drive? An older spinner is just fine for testing.
    Put it inside an empty slot and try a clean install.
     
  2. jiteshp88 macrumors newbie

    Joined:
    Jan 10, 2019
    #11452
    got it to work, removed the gt120 and it works!
     
  3. flygbuss macrumors regular

    flygbuss

    Joined:
    Jul 22, 2018
    Location:
    Stockholm, Sweden
    #11453
    that's good. No issues with the 660?
    The GPU was my first guess since safe mode worked, that's why I asked..
     
  4. jiteshp88 macrumors newbie

    Joined:
    Jan 10, 2019
    #11454
    Works well so far. Will test with photoshop and stuff over coming days
     
  5. jhowarth macrumors 6502

    Joined:
    Jan 13, 2017
    #11455
    Make sure you haven't applied the legacy video driver patches because of your GT120 as those will destabilize the GTX660 drivers.
     
  6. DaniloGeekDude macrumors regular

    DaniloGeekDude

    Joined:
    Jun 17, 2018
    #11456
    Latest Beta (10.14.3 Developer's Beta 4) successfully updated via OTA.

    Screen Shot 2019-01-10 at 2.50.18 PM.png

    This time I didn't have to re-ran macOS Patch Updater 1.2.3 's macOS Post Install process.
     
  7. Toospiny macrumors newbie

    Toospiny

    Joined:
    Sep 25, 2018
    #11457
    Hello! My computer runs currently mojave 10.14.0 very well. Now the update to 10.14.2 is released in my control panel.

    I see on the @dosdude page that I must install version 10.14.1 first before updating to 10.14.2.

    But, how do I download it? Since the store only gives me option for 10.14.2

    Thanks!!!
     
  8. DanieleDN macrumors newbie

    DanieleDN

    Joined:
    Jan 10, 2019
    Location:
    Italy
    #11458
    Hello everybody, I'm a proud user of the macOS Mojave patcher.
    I've an early 2008 MacBook Pro with this specs:
    - 15" display
    - Core2 Duo 2.5 GHz
    - 6 GB DDR2 RAM
    - 512 MB Nvidia GeForce 8600M GT
    - 500 GB SSD
    Thank you so much, because, despite the age of my Mac, I can use Mojave smoothly.

    I want to ask you only two things:

    1) Is there a way to use the Mac App Store, I haven't been able to download anything (I've used the traditional way to download apps)

    2) My Mac has the "famous" BCM 4321 AirPort card. Is there a way to make it works under Mojave? Or, if necessary, there are compatible cards? Now I'm using an USB Wi-Fi adapter, but it needs always one of my two USB hubs (even better than the lack of connectors of newer MacBooks)
     
  9. roronl macrumors member

    roronl

    Joined:
    Jul 8, 2016
    Location:
    The Netherlands
    #11459
    10.14.1

    The Mojave 10.14.1 update does NOT install properly on unsupported machines, and could result in an unbootable OS. If you want to install the 10.14.1 update (and are not currently running 10.14.1), perform the following steps:

    • Download the latest version of Mojave Patcher
    Download the installer using the Tools menu of Mojave Patcher
    • Create a patched USB installer
    • Boot from that, and install 10.14.1 onto the volume containing an older release.
    • Once done, apply the post-install patches, and you should now be on 10.14.1.

    (copy from: http://dosdude1.com/mojave/ )
    --- Post Merged, Jan 11, 2019 ---
    To use the store app updates, the system must use APFS.
     
  10. Pinarek macrumors member

    Pinarek

    Joined:
    Sep 16, 2009
    Location:
    Germany-Berlin
  11. flygbuss macrumors regular

    flygbuss

    Joined:
    Jul 22, 2018
    Location:
    Stockholm, Sweden
    #11461
  12. Pinarek macrumors member

    Pinarek

    Joined:
    Sep 16, 2009
    Location:
    Germany-Berlin
    #11462
    Yes, the beta4 really came out, please excuse me, I was not up to date.
     
  13. Romanesq, Jan 11, 2019
    Last edited: Jan 11, 2019

    Romanesq macrumors 6502a

    Romanesq

    Joined:
    Jun 16, 2003
    Location:
    Hoboken
    #11463
    Using a similar configuration: same 4,1 2008 model, RAM & SSD.

    1) On 10.14.2 Mojave, I tested a download from the App Store, "Tactical Monsters" and it downloaded and started fine. Not sure your Mojave version. Seems fine here.

    2) Replaced the original wifi card some years ago with an Atheros 9380. Had to use a usb Wifi adaptor and update it before it would work with Mojave. There are similar wifi cards available on Amazon and eBay for about $12 that will drop right into the slot inside the laptop.

    Good luck!
     
  14. DanieleDN, Jan 11, 2019
    Last edited: Jan 11, 2019

    DanieleDN macrumors newbie

    DanieleDN

    Joined:
    Jan 10, 2019
    Location:
    Italy
    #11464
    Thank you so much!

    P. S.

    I have the first stable release of macOS 10.14
     
  15. tracer5, Jan 12, 2019
    Last edited: Jan 12, 2019

    tracer5 macrumors newbie

    tracer5

    Joined:
    Aug 20, 2017
    Location:
    Hawaii - Big Island
    #11465
    MBP mid-2009 15-inch
    3.06 GHz Intel Core 2 Duo
    MBP 5,3 Latest Beta 10.14.3 Developer's Beta 4 (18D38a)) successfully updated via OTA.

    The boot rom has been patched using the Dosdude1 APFS Rom Patcher v2.0. All Dosdude1 post install patches have been applied except the APFS patch.

    Observed strange behavior:
    Attaching a Firewire 800 external HDD crashes the system, possible a kernel crash, followed by a re-boot loop with no backlight.
    Once the Firewire HDD is removed and upon rebooting the display backlight remains OFF, but for a short time the apple logo and progress bar is normal with backlight, then no backlight.
    I discovered that while the apple logo is backlit during boot I can increase and decrease the backlight intensity from the keyboard function keys (F1, F2). Then the backlight is restored and the system boots normally.

    Note of comparison. When adding a Firewire 800 HDD to a supported MBP (13 inch Mid-2012, 10.14.3 Developer's Beta 4 (18D38a)) there is only NORMAL behavior, everything works.

    Has anyone else noted this behavior? If so, is there any understanding of what is happening and a possible fix.
     
  16. macinfo, Jan 13, 2019
    Last edited: Jan 13, 2019

    macinfo macrumors newbie

    Joined:
    Aug 29, 2007
    #11466
    Do you also encounter the keyboard backlight turned on after every reboot? Just want to know, if my MacBookPro4,1 is a exempton here, or if that is to be expected behaviour.

    Also two-finger clicks on the trackpad (equivalent to right-button mouse clicks) are not recognized on mine.

    Other than that, I’m really glad it works so nicely (macOS 10.14.2).
    Again, thanks to dosdude1 and all the others who contribute to this project!
     
  17. DanieleDN macrumors newbie

    DanieleDN

    Joined:
    Jan 10, 2019
    Location:
    Italy
    #11467
    I can see the keyboard backlight turned on after every reboot, but the two-finger click system works.
     
  18. hophop3 macrumors newbie

    Joined:
    Jan 8, 2019
    #11468
    Next try.
    Can anyone help me?
    I moved the installaion of Mojave on my MacBook End 2009 (with the help of mojave patcher) to a new MacBook Air.
    Now I‘ve got some issues (Night Shift for example). So I‘m searching for information how to undo the installation of the mojave patcher.
    Thanks for help
     
  19. tracer5 macrumors newbie

    tracer5

    Joined:
    Aug 20, 2017
    Location:
    Hawaii - Big Island
    #11469
    Beware: Malware/Virus scanners identify and remove some but not all of the Dosdude1 patches resulting in an unbootable computer, and the USB ports won't boot a USB stick. I have experienced this problem and was only able to recover using Target disk mode to re-apply patches to the target computer SSD. Target Disk Mode is an easy way to recover short of removing the SSD and re-formatting it. All my data was undisturbed.
     
  20. Julian Marius Fairfax macrumors 6502a

    Julian Marius Fairfax

    Joined:
    Jun 11, 2018
    Location:
    Switzerland
    #11470
    You couldn't boot with the option key and select the usb?
     
  21. tracer5 macrumors newbie

    tracer5

    Joined:
    Aug 20, 2017
    Location:
    Hawaii - Big Island
    #11471
    That is correct. The exact behavior is that with the option key I can see the bootable USB stick, but the computer MBP5,3 won't boot. I have several bootable systems on USB including Linux, no joy!
     
  22. Julian Marius Fairfax macrumors 6502a

    Julian Marius Fairfax

    Joined:
    Jun 11, 2018
    Location:
    Switzerland
    #11472
    That sounds like a problem with your usb stick. Make an internal partition with the full installer system. It’s great for easy patching and reinstalling if things go wrong. 10Gb should do.
     
  23. tracer5 macrumors newbie

    tracer5

    Joined:
    Aug 20, 2017
    Location:
    Hawaii - Big Island
    #11473
    No... there is no problem with my USB sticks. I explored that possibility by trying them in another mac, no problem. As I stated I have several "systems' on various USB sticks, none work in the crippled mac, but do work in the same mac after using Target Disc Mode to re-install the patches. My point is that Malware and Virus scanners are problematic for Dosdude1 patches as they are identified as a malware infection.
     
  24. macinfo macrumors newbie

    Joined:
    Aug 29, 2007
    #11474
    That’s interesting, so you’re able to initiate a 'right-mouse-click' with two-finger tap + trackpad button click? Only thing I can get to work is two-finger tap as 'right-mouse-click' (without pressing the trackpad button).

    Problem with just tapping is, that I sometimes inadvertently click on icons or move windows around. Maybe I can get accustomed to it, though.
     
  25. DanieleDN, Jan 13, 2019
    Last edited: Jan 13, 2019

    DanieleDN macrumors newbie

    DanieleDN

    Joined:
    Jan 10, 2019
    Location:
    Italy
    #11475
    I think there is something about settings.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page