macOS 10.14 Mojave on Unsupported Macs Thread

Discussion in 'macOS Mojave (10.14)' started by dosdude1, Jun 4, 2018.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. FarmerBob macrumors member

    FarmerBob

    Joined:
    Aug 15, 2004
    #12401
    "THANK YOU!!" Nicely thought of and done.

    Can't wait to put 10.14.4 on my machine . . .
     
  2. joelw135 macrumors 6502

    joelw135

    Joined:
    Oct 15, 2008
    Location:
    New Jersey, USA
  3. Pinarek macrumors member

    Pinarek

    Joined:
    Sep 16, 2009
    Location:
    Germany-Berlin
    #12403
    where is the new Patcher please ? actual is 1.2.3, have the new Patcher a new Number ?
     
  4. DaniloGeekDude, Mar 4, 2019
    Last edited: Mar 4, 2019

    DaniloGeekDude macrumors 6502

    DaniloGeekDude

    Joined:
    Jun 17, 2018
    #12404
    10.14.4 Beta 4 (Developer) installed on my Unsupported MBAir4,2.

    Screen Shot 2019-03-04 at 2.11.30 PM.png

    I was able to successfully install the latest Mojave developer beta doing the following:
    • OTA --- System Preferences | Software Update.
    • Ran @dosdude1's Mojave Patcher 1.2.3's macOS Post Install.
    • Rebuilt cache prior to rebooting.
    • Rename my GLDriver file (in my device it is AppleIntelHD3000GraphicsGLDriver) from bundle extension to backup extension.
    • The previous step was necessary for me to successfully boot.
    Screen Shot 2019-03-04 at 3.12.55 PM.png

    I believe I still do not get graphics acceleration. Hoping that this anomaly will be resolved by the time GM is released (Fixed by Apple or @dosdude1's excellent patcher app).

    Fingers' crossed.
     
  5. ASentientBot macrumors 6502

    ASentientBot

    Joined:
    Jun 27, 2018
    Location:
    the System suitcase
    #12405
    Damn. I can't see this fixing itself at this point. Looks like it might be time for some more investigation...
     
  6. dosdude1 thread starter macrumors 68000

    dosdude1

    Joined:
    Feb 16, 2012
    #12406
    FULL acceleration with 10.14.4 on non-Metal GPUs ACHIEVED! More info coming soon, once I finalize all the necessary modifications.

    Screen Shot 2019-03-04 at 11.27.46 PM.png
     
  7. DaniloGeekDude macrumors 6502

    DaniloGeekDude

    Joined:
    Jun 17, 2018
    #12407
    That will be great @dosdude1 Thanks so much for your efforts. Looking forward to it.
     
  8. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    Switzerland
    #12408
    I bet it’s a windowserver related modification.
     
  9. visberry macrumors regular

    visberry

    Joined:
    Apr 25, 2016
    Location:
    New Zealand
    #12409
    Great work!
     
  10. dosdude1 thread starter macrumors 68000

    dosdude1

    Joined:
    Feb 16, 2012
    #12410
    Alright, got everything figured out! To get acceleration working under 10.14.4 with a non-Metal GPU, just download this archive, extract it, cd into the extracted directory using Terminal, and then run ./install.sh. Please ensure you have the Legacy Video Card Patch installed properly (you can re-apply it with the post-install patch, or re-install it using Patch Updater after running the script just to be sure). After rebooting, you should now have full graphics acceleration!

    Screen Shot 2019-03-05 at 12.53.14 AM.png
     
  11. FarmerBob macrumors member

    FarmerBob

    Joined:
    Aug 15, 2004
    #12411
    Well while you all were discovering the cure for Cancer . . .

    I was trying the latest version of the install and can't get past this . . .

    Deadend.jpg

    The White Whirlygig is actually light white. But each time it circles it stays and builds with each rotation until it's bright white and the whole thing hangs. MBP 7,1.

    I know in our genes we have the need to mess with this stuff, but I'm just gonna wait for the GM's. It was fun when fixes were easy. Oh god, I'm getting old . . .

    You all are great!! dosdude1, you are a god among gods. TTFN!!
     
  12. dosdude1 thread starter macrumors 68000

    dosdude1

    Joined:
    Feb 16, 2012
    #12412
    That's because of the graphics acceleration issues... Apply the patch I posted above, and that will fix your issue (you can boot Safe Mode to do so).
     
  13. FarmerBob macrumors member

    FarmerBob

    Joined:
    Aug 15, 2004
    #12413
    Thank You!! I'll play tomorrow after I get my new Gigabit Fiber installed.

    Right now I have to do a tribute for a fallen Firefighter that my group is having an event for.

    Thanks.
     
  14. DaniloGeekDude macrumors 6502

    DaniloGeekDude

    Joined:
    Jun 17, 2018
    #12414
    Sweet. I'm going to try this later on my MBAir4,2 with an Intel HD Graphics 3000.

    Thanks again @dosdude1.
     
  15. 16v macrumors regular

    Joined:
    Jul 13, 2018
    #12415
    Do i need this patch on a mid 2009 15" and a 2011 13"? Both with mojave .3 (official release)?

    And how to check if i have full gfx acceleration?
     
  16. Scryer macrumors newbie

    Joined:
    Mar 5, 2019
    #12416
    Hello. Does it mean that now we may install mojave on imac 2011 with radeon gpu, and have full acseleration support? Tnx
     
  17. jackluke macrumors 65816

    jackluke

    Joined:
    Jun 15, 2018
    #12417
    This is a great news, because I expect that the same method will be valid also for the future 10.15 on fall 2019.
    --- Post Merged, Mar 5, 2019 ---
    Once again, great insight about those legacy frameworks.
     
  18. UbiMac macrumors newbie

    Joined:
    Mar 5, 2019
    #12418
    Hello together,

    I'm using a MacBookPro 5.3 (15 inch, Mid 2009, OS X El Capitan, SSD, 8 GB RAM) and tried to install OS X Mojave with the Patcher.

    The creation of a USB Stick worked well but after booting from the USB Stick a "NO" Symbol was shown every time I tried to boot.

    Can someone please help my to tell my the problem?

    Thank you and greatings from Germany
     
  19. avz macrumors regular

    Joined:
    Oct 7, 2018
    #12419
    It would be great to have MacBook5,1 marching on into the future with the 10.15!
    --- Post Merged, Mar 5, 2019 ---
    Have you tried a different USB stick?
     
  20. bbfc, Mar 5, 2019
    Last edited: Mar 5, 2019

    bbfc macrumors 68040

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #12420
    Installed 10.14.4. Reapplied the patches but can’t boot in to normal or safe mode to install the graphics acceleration patch. I just get the the prohibitory sign (for safe mode) or an endless spinning cog (for normal mode) all the time. Any ideas? How can I install the patch?
     
  21. indigotheory, Mar 5, 2019
    Last edited: Mar 5, 2019

    indigotheory macrumors regular

    Joined:
    May 1, 2009
    #12421

    Dosdude1 what do you mean by "cd into the extracted directory using Terminal"

    I've had a go and I get this message, I haven't much experience with using the terminal app
     
  22. jhowarth macrumors 6502

    Joined:
    Jan 13, 2017
    #12422
    What was the nature of the fix? Did the patching needed to be extended for the existing backported libraries or were additional libraries required to be added to the existing backported ones?
     
  23. telepati, Mar 5, 2019
    Last edited: Mar 5, 2019

    telepati macrumors regular

    telepati

    Joined:
    Jan 20, 2009
    Location:
    istanbul
    #12423
    @dosdude1 could you please explain what is wrong this patch "Backlight Control Patch" Last night I tried to re-install one by one all the patches for test and when I tried to re-install this patch machine never boot and starts looping. Why this happening?

    Also, I realize something there is no Backlight Control Patch on the Post Installation stage for iMac 9,1;

    IMG_0609.jpg

    Also, USBOHCI Support Patch looks like patching on the Post Installation Stage but when we are boot the system it doesnt show on the Patch Updater and your new Verify Pacth Integrity doesnt find it.

    Screen Shot 2019-03-05 at 16.25.31.png
     
  24. ASentientBot macrumors 6502

    ASentientBot

    Joined:
    Jun 27, 2018
    Location:
    the System suitcase
    #12424
    Amazing work @dosdude1 !!!

    Please explain your modifications to GPUSupport.framework and OpenGL.framework. Are these simply copied from an earlier release? Or have you patched them in some way? I don't want to just brainlessly install something that I don't understand, no matter how awesome it is.
     
  25. hfogel macrumors newbie

    hfogel

    Joined:
    Mar 5, 2019
    Location:
    Philadelphia
    #12425

    Hi Collin, I'm using a Mac Pro 3,1. It was running El Capitan, but I'm a heavy Adobe user, so needed to update for the latest batch of Creative Cloud updates to install. It has an Nvida Fermi Quadro 4000 for Mac video card installed, and 16 GB of RAM. Booting off a SSD in an OWC PCI card. Followed directions to the letter, but, now I have a system that will only boot a short way, then I get an error message, that the system has encountered an error. If you hit a key, it will start to load, about 1/4-inch on the bar, then shut down with a black screen. It wouldn't allow me to boot into the recovery volume, so I rebooted to my USB drive, selected the Patch the Recovery option, and it now allows me to boot into it. I've also used the option for Legacy Video Card in the Post Install Tool.

    But it still won't boot past that 1/4 inch into the progress bar. There doesn't seem to be any FAQ or explanation of what the legacy patch tool options do, or when to use them. So, any help would be great. I'm wondering if the issue is the OWC Accelsior S card (https://eshop.macsales.com/item/OWC/SSDACL6G.S/)? I'm assuming that since the system will boot off the USB drive, that things like the video card, RAM, etc. all are working fine, so whatever is happening, happens almost immediately. I've been unplugging external drives, etc., to rule that out.

    I read the note about the archive, but not quite sure how to install, but will give it a whirl. Love a short video tutorial.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page