OS X El Capitan on Unsupported Macs

Discussion in 'OS X El Capitan (10.11)' started by TMRJIJ, Jun 5, 2015.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. atvusr macrumors 6502

    atvusr

    Joined:
    Apr 5, 2010
    #851
    No, because macOS 10.12 Sierra requires the SSE4.1 CPU instruction set which is only supported by the 2008 'Penryn' CPU models or newer.
     
  2. skyfly555 macrumors member

    skyfly555

    Joined:
    Apr 26, 2016
    #852
    Hello, friends!

    I'm just writing from my Sierra Acer 5315 hackintosh (GMA X3100, upgraded to Core2Duo Penryn T9300).
    TRMJIJ, and the rest of OS X Hackers: Thank You :)

    OS X Hackers' GMA X3100 kexts (downloaded from here: http://dl.osxhackers.net/Kexts/GMA X3100 Kext Installer.pkg) work as good as they work with El Capitan.

    I wonder what these kexts are, if somebody can tell it to me: http://dl.osxhackers.net/Kexts/Beta/GMA X3100 Kexts.pkg.

    It's an absurdity to see how an old Acer laptop can be a better macOS machine than a Real Mac :(

    Captura de pantalla 2017-04-14 a las 17.47.06.png
     
  3. tidal macrumors newbie

    tidal

    Joined:
    Jul 24, 2010
    #853
    I'm trying to get El Capitan installed on a Mac mini 2,1 and I'm using MCPF 2.0.1 and I'm stuck with the installer rebooting halfway through and never finishing. I've tried different methods of creating the MCPF external disk with no luck. Even tried replacing the boot.efi with Pike's. I also tried macOS Extractor 1.4.5 beta 5 with even worse luck. I've read through a lot of pages but not all and can't find a solution. Tried looking at the install.log with no luck except font errors.

    What could I be missing? Would someone point me to a post if there is one?
     
  4. hellix macrumors newbie

    Joined:
    Apr 22, 2017
    #854
    Hello. Tell me please, is it possible to install El capitan by method 2 on macbook 4,1 (2008)?
     
  5. bbnck macrumors regular

    Joined:
    Mar 19, 2009
    #855
    Jee, 667 MHz memory! What year is this machine from?
     
  6. atvusr, Apr 24, 2017
    Last edited: Apr 24, 2017

    atvusr macrumors 6502

    atvusr

    Joined:
    Apr 5, 2010
    #856
    The Acer Aspire 5315 Notebook was first available from October 31, 2007 - according to the Product information on http://www.Amazon.co.uk/dp/B000VPJDPM/ .

    It should be highlighted again that the above described Acer Aspire 5315 runs macOS 10.12 Sierra as a Hackintosh.

    This is less helpful for people with an original 2006/2007 Apple Mac since they have to upgrade the CPU or the Logic Board to run macOS 10.12 Sierra.

    For macOS 10.12 Sierra on older, unsupported Macs see the Threads:

    https://forums.macrumors.com/threads/macos-10-12-sierra-unsupported-macs-thread.1977128/

    as well as:

    https://forums.macrumors.com/threads/2006-2007-mac-pro-1-1-2-1-and-macos-sierra.1977271/
     
  7. tidal macrumors newbie

    tidal

    Joined:
    Jul 24, 2010
    #857
    I moved on and got Yosemite installed.
     
  8. skyfly555, Apr 26, 2017
    Last edited: Apr 26, 2017

    skyfly555 macrumors member

    skyfly555

    Joined:
    Apr 26, 2016
    #858
    Yes, this Acer is a 2007 hackintosh. No, my idea is not talking about it, but just stating the GMA X3100 kexts from OS X Hackers work like a charm with Sierra 10.12.4.

    Other way, and talking about Capitan, I realised yesterday method 3 doesn't work with 10.11.6, but it works from 10.11.0 to 10.11.5
    I could see, too, when cloning from a 10.11.0 backup, that the the boot.efi from @vsbalint70 didn't disable SIP. And that the kexts and all the terminal steps of the method 3 could be done with a Yosemite machine, but not with a El Cap 10.11.6 machine, because, although SIP was disabled, the El Cap 10.11.6 machine said all the time "Permissions wrong, omitting kexts..." and this type of messages and it didn't obey me when I tried to do some "chown" and "chmod" to modify owner and permissions of the kexts.

    So, in brief, I remember method 3 was developed when El Cap 10.11.5 had just been released, it seems Apple decided to make some changes when realeasing 10.11.6 that "destroy" our "method 3".

    I'm supposed to have 2 or 3 days to spend some time with my unsupported macs, and I'll try to get SIP disabled using the last version of rEFInd, because it's the base of Clover bootloader, which has let me to install El Cap (and Sierra, too) on my old 2007 Acer hackintosh. I hope that will let us to be able to:
    1- Have SIP disabled, so no more problems with the kext caches and so on;
    2- Have El Cap 10.11.6 on our old Macs.
    When I discovered method 3, the version of rEFInd of that moment didn't let us to disable SIP (that was one of the things I tried to do when I was creating the method, and it failed). It seems the actual version lets us to do that.

    I will inform you in a few days if a "new method 3" can be created or not, with rEFInd and El Cap 10.11.6
    If you have time, you know the idea, check it, too :) Maybe you can be the creator of the "new method 3".

    If someone has a non-SSE-4 kernel, please tell it to me, because if rEFInd disables SIP in El Cap, this is the first step to install Sierra on our EFI 32 MB 2,1-3,1-4,1 and MBP 2,1-3,1.
    The second step is the non-SSE-4-kernel. I hope AMD people, who build kernels for their AMDs hackintoshes, can finally create that kernel: it would serve for their old AMDs and for our Core2Duo T7000 series CPUs, too.
    The third step would be to check if our yosemite-pike's-boot.efi let us to boot Sierra from it.
    Fourth step: a tutorial for all of us :)
     
  9. mattschwantes macrumors newbie

    Joined:
    Dec 27, 2016
    #859
    I used a variation on your method 3 for my MacBook 2007, first using Clover on a Hackintosh to get the external HDD running 10.11.6. This was then installed into the MacBook.

    To make the jump from 10.11.5 to 10.11.6 different USB kexts were required (Ver.3 instead of Ver.2). Even so, every time Apple does a security update, my USB stops working and it is required to manually reinstall some of these same Ver.3 kexts. Hope that is useful to you.
     
  10. skyfly555, May 3, 2017
    Last edited: May 3, 2017

    skyfly555 macrumors member

    skyfly555

    Joined:
    Apr 26, 2016
    #860
    Thank you very much for this info, that's great, and, yes, from a hackintosh you can clone the HDD with Carbon or SuperDuper and it will work, as you have said.

    Hello!

    I've checked it all.
    The reality, in 3 facts, all related to rEFInd:
    NOTHING IMPROVED
    1- With EFI 32 from Yosemite, you cannot disable SIP with rEFInd.
    SOME IMPROVEMENTS
    2- With EFI 32 from Pike Capitan, you can disable SIP with rEFInd, but, 30 seconds later, you get a KP. I've done that, modifying the code, just to have every macbook or mbp recognised as it was a MBP 3,1.
    This is the MOD required, into this file: https://github.com/Piker-Alpha/macosxbootloader/blob/El-Capitan/src/boot/PlatformExpert.cpp

    Line 279:
    From
    else if (memcmp((CHAR8 *)boardId, (CHAR8 *)"Mac-F42187C8", 12) == 0)
    to
    else if (memcmp((CHAR8 *)boardId, (CHAR8 *)"Mac-F32487Z7", 12) != 0)

    We invent a board-id that doesn't exist (Mac-F32487Z7) and we say to the compiler that every mac with a board-id different to that fake Mac-F32487Z7 has to be redefined to a MACBOOKPRO_31 (this happens in line 275).
    One this is done, you simply delete lines from 277 to 283.
    I don't attach the "new" boot.efi", because it doesn't work.

    TOTAL IMPROVEMENT
    If you have an unsupported EFI64 Mac, and you can use the default El Cap boot.efi (for example, MACBOOK 4,1), you can disable SIP installing rEFInd.
    How to do that? http://www.rodsbooks.com/refind/installing.html#osx

    I have to say thanks to Roderick W. Smith, creator of rEFInd, who has helped me answering an e-mail full of questions, I'm very grateful to him for his help.

    So, one year later of creating the "method 3", we are stuck in the same point we were: we need a boot.efi that we don't have, and it seems nobody knows how to modify Pike El Cap boot.efi to get it running without KPs.
    This is the only thing that doesn't let us to have a good El Cap in our old Macbooks and MBPs.


    And I don't know how to do that, so, I have installed again Yosemite on my old MB2,1.

    I attach an image: it's using the Pike El Cap boot.efi, modified as I've explained in point 2, just before the KP, having booted it in single user mode. If you use the normal boot you can see the GUI loaded, but in 20-30 seconds, you have the KP and macbook reboots. Before the rebooting moment, you can see how all the kexts are loaded (not the symbol that says the computer is connected to a second screen, and seeing the good resolution from the GMA X3100 kexts loaded), and this without doing the half of the steps described in "method 3" (without having to creating kernelcache, prelinked kernel...).
    IMG_20170428_001224.jpg
     
  11. skyfly555 macrumors member

    skyfly555

    Joined:
    Apr 26, 2016
    #861
    Maybe this app could help to disable SIP, but I don't have time to check more things.
     
  12. artooks macrumors newbie

    Joined:
    Feb 20, 2015
    #862
    Hi Guys, I have been using El Capitan in my Mac Pro for 1.5 years yesterday out of the blue the system started to restart constantly, I tried everything cleaned the tower, swam the disc but what ever I do I can't seem to bring back to normal, now I am doing an Apple Hardware Test but turned out " OK" and it also did not crash during the testing phase :) This computer really drives me crazy, I did also a Pram so is there a new release of Pikers Boot Efi for El Capitan or still everyone using the old one, can someone please help me.
     
  13. astonmarkus macrumors newbie

    Joined:
    May 27, 2017
    #863
    Sorry for my bad english i'm from Austria.

    I have two MacBook's. I want to install El Capitan on one of them (MacBook 13" Late 2007 A1181 Black, Core 2 Duo T7500 2GB Ram Mac OSX 10.7.5). The other one is my "Daily Driver" (MacBook Pro Retina 15" Late 2013 A1398 i7-4750HQ 8GB Ram on MacOS Sierra).

    The El Capitan.app ist directly from the Appstore downloaded with my MacBook Pro. (And i copied it to the Application Folder of the 2007 MacBook, where MacPostFactor is also installed.

    I tried many ways to install it:

    MacPostFactor directly on the 2007....when i want to install it directly to the MacBook i get a Error Code One wich means there is no installer but that could not be because....

    MacPostFactor over a USB Drive (I tried it from the MacBook and the Pro with the same result)....It finished perfectly but when i want to boot it on the MacBook (With "alt" while booting) i can click at the Boot Menu on the Stick, but it boots me directly into 10.7.5 on my Harddrive. Neither the Manual with the --set Boot (When i do that, it asks me for my Password but then it do nothing...it don't ask me from where to boot or something) and the same result i get when i boot to Singe-User Mode...i tried it with the .plist command but nothing happens.

    And MacOS Extractor....

    When i download it on my Sierra MacBook Pro it says that the Download is Corrupt and i should give it to the Trashcan or "Cancel" but i don't can start it.

    When downloaded on the MacBook with 10.7.5 it startet normal, but when it starts to operates after a few seconds it says that the program is finished but the USB Stick is empty...

    Please help :)
     
  14. tedbm, May 29, 2017
    Last edited: May 29, 2017

    tedbm macrumors newbie

    Joined:
    May 29, 2017
    #864
  15. eyez73 macrumors newbie

    Joined:
    Apr 10, 2015
    #865
    Could anyone let me know a good video tutorial on how to do this?

    I'm completely lost on which drive is install too!
     
  16. tedbm macrumors newbie

    Joined:
    May 29, 2017
    #866
  17. TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #867
    macOS Extractor v1.42


    A macOSE update is recommended to assist you in installing macOS Sierra, El Capitan, Yosemite, Mavericks, and Mountain Lion on your old Mac. Also, by updating the system software of your Mac, you can enjoy various additional features and enhanced security. Always use to the latest version.
    Never download this from any other provider. All links must be from these forums or directly from our server. This is to ensure that nothing was tampered with and that you have the most reliable and tested software.


    This Update Includes:
    • Maintenance script now compresses Dock app resources
    • [dev] AutoPatch main script now includes variables for each OS and steps required
    • [dev] Graphical Kexts Web Installers now addresses changes in version control
    • Address differences between Mountain Lion and other OSs’ BaseSystem
    • Hides Framework error from installer logs (Not Important)
    • Address Issue that would cause Mountain Lion Patching to fail due to file name errors.
    • Adds a PostInst script within the AutoPatch that can be addressed through the Installer’s terminal
    • Graphical Kexts are automatically downloaded to the Installer for use during patching.
    • AutoPatch now verifies that the Installer is ‘bless’ to boot.
    • Maintenance Script is now fully executable and includes more optimizations.
    • Address issue where Graphics Kext Installer fails even when the kexts are installed.
    • Addresses Rich Text Formatting that causes some scripts to not finish
    • Fixed issue where the Graphical Installer fails after clearing kernel cache
    • Addresses issue where the AutoPatch refuses to complete all of its tasks within the Target Partition/Image
    • Fixes issue where some scripts are in rich text formatting
    • Replaces brightness app with a new app recommended by a member is the Yosemite thread.
    • Smart OS detection
    • Installer Logs now echo its current process to help diagnose where more issues may occur.


    Download Size: 70 - 170 MB


    Prerequisites

    Tested Macs listed below. Here are the minimum requirements:

    - Running 10.7 Lion
    - At least 2GB of RAM.
    - A copy of Yosemite or Mavericks in Applications Folder (.app file preferred)
    - 15 GB of free space from USB or HDD Partition.

    -MacBook2,x
    -MacBook3,x
    -MacBook4,x
    -MacBookPro2,x
    -MacBookAir1,1
    -MacMini1,x (C2D upgraded)
    -MacMini2,x
    -iMac4,x (C2D can be upgraded)
    -iMac5,x


    We DON'T assist with Hackintosh. All private messages/emails involving installing OS X on non-Apple hardware will be redirected to another support team.


    How to Use It:
    1. Download macOS Extractor
    2. Install it. Choose a version of macOS/OS X to get the correct patches.
    3. Open the AutoPatch in your Applications and view to corresponding guide for the OS you choose.

    --- Post Merged, May 30, 2017 ---
    I will start on macOSE v1.43 Betas over the weekend. Please send feedback on the new Bootloader and PostInst script
     
  18. skyfly555 macrumors member

    skyfly555

    Joined:
    Apr 26, 2016
    #868
    The link, in post #1, it's ok: https://www.dropbox.com/s/pcru3stwe36t2r3/all-kexts-nov16.zip?dl=1
    --- Post Merged, Jun 1, 2017 ---
    Please, one question, TRMJIJ, do we have an EFI32 boot.efi capable of disabling SIP? Have you included that in our latest version of macOS Extractor?
    Thank you,
     
  19. Gpl macrumors newbie

    Joined:
    Jan 13, 2017
    #869
    Thanks TMRJIJ !
    --- Post Merged, Jun 1, 2017 ---
    iMac 4.1 with 5.1 firmware on Lion 10.7.2 macOS Extractor v1.42 won't start
     
  20. TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #870
    Is it stuck at booting into the installer or the partition you installed macOS to?
    I'm testing a version of the EFI32 boot.efi in this version. When testing it seemed to work a few times on certain models. I might have to edit another one in v1.43 though.
     
  21. Gpl macrumors newbie

    Joined:
    Jan 13, 2017
    #871
    it stuck at booting into the installer
    --- Post Merged, Jun 1, 2017 ---
    when i try to run the installer nothing happens
     
  22. astonmarkus macrumors newbie

    Joined:
    May 27, 2017
    #872
    MacBook 3,1 A1181 Late 2007 Core2Duo T7500 2,20GHz GMA X3100 2GB Ram OS X 10.7.5
    OS X El Capitan installer is the official one downloaded on the Appstore from a Late 2013 15" MacBook Pro Retina.

    Wont start into the Installer (get a "with one Line crossed Circle) and nothing happens.
    (I tried install El Capitan because logical…..OS Sierra is not compatible with this mac)
     
  23. Gpl macrumors newbie

    Joined:
    Jan 13, 2017
  24. TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #874
    Don’t forget to run the PostInst script from the terminal after installation. This is to ensure the USB Kent’s are added to the partition
     
  25. fanfzero macrumors member

    Joined:
    Oct 8, 2016
    #875
    After installing airdrop enabler, dock and wallpaper aren't shown anymore. I've tried to run the uninstall package, but it gives me an error after intalling it and nothing happens.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page