OS X El Capitan on Unsupported Macs

Discussion in 'OS X El Capitan (10.11)' started by TMRJIJ, Jun 5, 2015.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. Wolwerine macrumors regular

    Wolwerine

    Joined:
    Jun 8, 2015
    Location:
    France
    #101
    Hi, again,,
    i'm stuck,,
    is there a guide to use IOService (point 20 i guess ),,i'm stuck here,,i open, but, how can i run it,
    someone had told me to use terminal typing this:
    " ioreg -lp IOService | grep board-id "
    i got a question,, should i type this above
    " ioreg -Ip IOService | grep Mac-F22788A9 " or that's incorrect? please,,feedback,,i'm stuck here,,
    i got this when i open IoService see screenshot,
    Thanks in advance. Capture d’écran 2015-07-11 à 16.24.11.png
     
  2. pulker macrumors newbie

    Joined:
    Jul 28, 2012
    Location:
    Italy
    #102
    Wolverine, when you type
    in Terminal, it tells you the Macbook model you are using. You simply need to patch the InstallableMachines.plist and the PlatformSupport.plist with those values you have (step 22 and 23). We have same Macbook, but actually I am with Yosemite 10.10.4. I will wait the final 10.11 version, before attempting the upgrade.

    PS: the app you are using has nothing to do with the patching process. It's only to simplify the identification of your model. But, the Terminal tells you all. You just needed to know that your Mac is the MacBook4,1. That's all.
     
  3. BruceWayne54 macrumors member

    BruceWayne54

    Joined:
    Mar 21, 2015
    Location:
    Austin, TX
    #103
    If I install the highlighted kexts (see screenshot) on El Capitan from my supported mac, do you think it might solve this problem?
     

    Attached Files:

  4. TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #104
    Probably not. For one IOUSBFamily.kext doesn't really do anything. Plus the issue might be deeper than just those Kexts.
     
  5. Wolwerine macrumors regular

    Wolwerine

    Joined:
    Jun 8, 2015
    Location:
    France
    #105
    Ok,,
    I got MacBook 13" Early 2008 Intel Duo2Core 2,40GHz 4G RAM 667MHz Intel X3100 144MB
    ok, i got already install Yosemite and Mavericks, now, i would love to try El Capitan,,
    After following step by step the guide,,i got this,,first time i chose to boot from USB Install ( first 3 screenshots ) after 1 and half minutes, he stops showing blacsncreen with a sign,,
    second time i boot, in boot single user mode, pressing " cmd S ",, and i get this, ( last 3 screenshots )
     

    Attached Files:

  6. atvusr, Jul 11, 2015
    Last edited: Jul 12, 2015

    atvusr macrumors 6502

    atvusr

    Joined:
    Apr 5, 2010
    #106
    That's the same result as on the MBP2,2 - like TMRJIJ said, the issue might be deeper than expected....
     
  7. Wolwerine macrumors regular

    Wolwerine

    Joined:
    Jun 8, 2015
    Location:
    France
    #107
     
  8. hugoZA macrumors newbie

    Joined:
    Jun 4, 2014
    #108
    I am also getting the 2/3 progress bar. Mac Pro 1.1 2.66qc 8gb ram with firmware updated to 2.1. Installed onto USB drive via Macbook Pro 15 Retina. Replaced both efi files and blessed the HD. Reinstalled the drive in the Mac Pro and boot. Boot drive shows as "EFI BOOT".

    The mouse cursor appears in the top left corner and I can move it around. When the progress bar stops around 2/3 and I click the cursor disappears and doesn't come back.
     
  9. Wolwerine macrumors regular

    Wolwerine

    Joined:
    Jun 8, 2015
    Location:
    France
    #109
    got El Capitan Installed on No Mac Machine, well, in fact, all my devices are compatible with apple software,,
    i got Assus P5QKL-AM
    Intel Core 2 Duo 2,93GHz
    4 Gb RAM DDR2 800MHz
    Nvidia GeForce GT 610 1024MB
    after getting EL Capitan Beta from Apple Store,
    i used Vanilla installation clover to finish,,
    ont issue i can't boot El Capitan without USB Install,,any tips to solve Screen Shot 2015-07-15 at 12.42.56.png this,??
    Thanks in advance,,
     
  10. PeterHolbrook macrumors 6502a

    Joined:
    Sep 23, 2009
    #110
    The blessing has to be done on the TARGET computer (i.e. your Mac Pro), not somewhere else.
     
  11. hugoZA macrumors newbie

    Joined:
    Jun 4, 2014
    #111
    Thanks. The problem ended up being GPU related. Booted off the GT730 and it worked fine. Card was not identified as a GT730 by El Cap, and there are no drivers from Nvidia yet. Reverted back to Yosemite.

     
  12. DebugFactory, Jul 27, 2015
    Last edited: Jul 27, 2015

    DebugFactory macrumors newbie

    Joined:
    Jul 27, 2015
    #112
    I was unable to use the .mpkg to patch the Recovery HD, however, I found another fix that may help those who need the Recovery partition.

    1. Open up terminal and type in the following:
    Code:
    defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
    2. Launch Disk Utility and use the new "Debug" dropdown menu to select "Show every partition"

    3. You will now see the Recovery HD as a partition to your main hard drive, right click (Control click) it and click mount "Recovery HD" the drive will now be visible in Finder

    4. Navigate to Recovery HD/com.apple.recovery.boot/

    5. Delete the PlatformSupport.plist that is present in the folder

    6. You can now reboot to the Recovery HD Partition

    If you would like to disable the "Debug" dropdown:

    1. Close Disk Utility

    2. Type in the following code in terminal:
    Code:
    defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
    Reboot your mac and the Recovery HD will be gone.

    Hope I helped anyone who needed it.

    NOTE: IF YOU DOWNGRADE YOUR MAC USING A TIME MACHINE BACKUP THE RECOVERY HD WILL BE UNAFFECTED SO YOU WILL KEEP THE RECOVERY HD OF WHATEVER OS YOU DOWNGRADE FROM. (in this case if you happen to be following this guide it will be El Capitan)
     
  13. darthgeekonius macrumors member

    darthgeekonius

    Joined:
    Apr 7, 2014
    Location:
    Maryland
    #113
    Update: I finally got it to work. I think the problem has to do with upgrade vs clean install. If you do a clean install, you just have to do rootless and replace the 2 efi files with the Piker ones for Yosemite. Each time you update though at least through beta 4 you have to replace the efi files again.
     
  14. TMRJIJ, Jul 27, 2015
    Last edited: Jul 28, 2015

    TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #114
    Have a awful lot of bug fixes for OSXE1.3B5:
    • Fixes an issue where the main Recovery Patcher script inside the installer doesn't read as UNIX causing the installation to fail (Thanks @DebugFactory )
    • Addresses an issue where Recovery Patcher doesn't add all board ids to PlatformSupport.plist
    • Adds Support for Mac Pro 1,1 and 2,1 (Certain Graphics Cards tested)
    • Addresses an issue where Graphics Disabler would sometimes fail installation even though it actually performed the tasks.
    • Adds Font Changer 1.0 with support for Helvetica Neue, Comic Sans, and San Fransisco.
    • Updated OS X Hackers App for preparation.
    • Fixed Issue where some Macs fail to install due to current RAM configuration.
    Still conversing with MLforAll about the chipset issue. If you have anymore workarounds feel free to update post 1.
     

    Attached Files:

  15. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #115
    I am a little unclear, has any EFI32 Mac OTHER THEN MP 1,1/2,1 been able to boot to El Capitan?

    Also, what does:

    • Adds Support for Mac Pro 1,1 and 2,1 (Certain Graphics Cards)
    Refer to? The unsupported cards in these machines are the X1300, X1900, 7300GT, and Quadro 4500. All other previous MP cards should work without any other hacks or fixes needed. And I doubt that there will ever be any way to make the excluded cards be fully functional. The EFI on them will enable basic screen function but nothing more.
     
  16. TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #116


    I just added the MP board IDs to the installers. I'm just clueless about the card 'upgrades' those Pro users use.
    All modern stock non-flashed PC graphics cards with AMD or Nvidia chipsets show work according to @Mr. Zarniwoop but I will hold that with a grain of salt.
     
  17. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #117
    Since somewhere back in 10.8.x Nvidia and AMD drivers have "self inited" their cards. So, no longer need a specific Mac EFI to get the card running in OS X. Even cards that never shipped in Macs. You can look inside the AMD kexts and see the lists of device ids that are supported. Nvidia keeps these lists hidden. Some iMac users have been able to use other MXM cards this way though they frequently have issues. But i can confirm that it works on Mac Pros. I have used a Titan-X on a 1,1, works fine.

    So, you get no boot screens but once computer gets to desktop it pops up.

    It seems from this thread that all other "unsupported" Macs have run into a brick wall due to USB not working. Curious if anyone has tried using Screen Sharing to log in remotely.
     
  18. atvusr, Jul 30, 2015
    Last edited: Aug 4, 2015

    atvusr macrumors 6502

    atvusr

    Joined:
    Apr 5, 2010
    #118
    Basically it boots on the EFI32 MBP2,2 - via USB only until two third of the progress bar (gets then stuck with 'No Entry' sign), via eSATA or via FireWire until the Desktop (Input-devices don't work then). It's always the same issue since the DB1/PB1, including the current Public Beta 4 (15A243d).

    Good idea. Yes, it works on the MBP2,2. This shows that OSX 10.11 basically runs on this machine.

    Interestingly, in the System Report are no USB-devices displayed, neither external (e.g. Thumbdrive) nor internal (Keyboard/Trackpad, Bluetooth/Infrared-Receiver, iSight-Camera).

    It seems that Apple has dropped the support for older Chipsets - in this case the Intel ICH7-M.

    I've tried to install the ATI X1600 Graphics Kexts - while it works flawless in OSX 10.10 Yosemite, the Kexts aren't recognized in OSX 10.11 El Capitan or cause a Kernel Panic.

    Apparently OSX 10.10 Yosemite is the last version for these older machines (except the MP1,1/2,1). Too many issues are to solve to get OSX 10.11 El Capitan running properly on the older, unsupported Macs ....
     
  19. LaurentR2D2 macrumors member

    Joined:
    Jul 24, 2011
    Location:
    Paris - France
    #119
    I want to try El Capitan on a special disk of my Mac Pro rev 1,1 / ATI Radeon HD 5870 1024 Mo. On IMZDL, I only find El Capitan beta 1 and delta updates for the other betas. Should I download all the delta updates from 2 to 6 and install them one by one until I reach beta 6 or can I only download beta 6 and install it over beta 1 ?

    Thank you
     
  20. atvusr macrumors 6502

    atvusr

    Joined:
    Apr 5, 2010
    #120
    Install the Developer/Public Beta 1 first and then update them via the App-Store. It's unfortunately not possible via App-Store to skip single Beta versions (e.g. DB versions 2-5), you have to update them sequentially.

    This is by the way the more appropriate Thread for the Mac Pro 1,1/2,1 and OSX 10.11: http://forums.macrumors.com/threads/2006-2007-mac-pro-1-1-2-1-and-os-x-el-capitan.1890435/ .
     
  21. TMRJIJ, Aug 5, 2015
    Last edited: Aug 8, 2015

    TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #121
    'Expecting' to finally release OS X Extractor 1.3 Beta 5 near the Today at around 11:59 PM EST barring that there are no embarrassing bugs.

    Final list of bug fixes/changes for OSXE1.3B5:
    • Fixes an issue where the main Recovery Patcher script inside the installer doesn't read as UNIX causing the installation to fail (Thanks @DebugFactory )
    • Addresses an issue where Recovery Patcher doesn't add all board ids to PlatformSupport.plist
    • Added Option to make Full Patch OS X Installer as Recovery HD in Recovery Patcher (For Script work Reference / Not functional yet)
    • Adds Support for Mac Pro 1,1 and 2,1
    • Addresses an issue where Graphics Disabler would sometimes fail installation even though it actually performed the tasks.
    • Fixes an Issue where some Macs failed to install AirDrop Enabler
    • Adds Font Changer 1.0 with support for San Fransisco.
    • Updated OS X Hackers App for preparation.
    • Fixed Issue where some Macs fail to install due to current RAM configuration.
    • Automated Kext Installers
    • NoSleep is not a standalone Beta Kext
    • New Installer Feature to allow people who already been successful with installation of OS X 10.9 - 10.11 to upgrade patch files without the need of OS X Installer App.
    • New Hidden Developers Folder for reference/editing of scripts.
    • No More Disappear App in future builds due to language issue. We have our own Hidden File Toggle to be installed in the Finder.
    • Added Beta USB, Bluetooth, and Ethernet Kexts for El Capitan (for Intel ICH7-M chipset models)
    Still conversing with MLforAll about the chipset issue. Please try the kexts provided and update in this thread of the issue. If you have anymore workarounds feel free to update post 1. Anymore bug fixes, please pm as soon as possible.
    Post 1 will be updated next week. Preview Guide for the Yosemite Thread will also be there.
    Overwhelming emails to continue to update the Yosemite Patch Files zip regularly. I will not stop updating that zip download and might have a El Capitan one.

    I apologize for the extreme delay. I know I missed a few El Capitan Beta Updates but I wanted to ensure that me, Nolan, and MLforAll fixed the ongoing issues with Yosemite and Mavericks.
    MacPostFactor will get the same quality treatment as MLforAll is starting from scratch for v1.1.
     
  22. TMRJIJ, Aug 8, 2015
    Last edited: Aug 8, 2015

    TMRJIJ thread starter macrumors 68020

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #122
    Here is OS X Extractor v1.3 Beta 5 / Public Beta 2.

    It is for Developers and people who can diagnose their Macs if something goes wrong.

    A OSXE update is recommended to assist you in installing OS X El Capitan, Yosemite, and Mavericks on your old Mac. Also, by updating the system software of your Mac, you can enjoy various additional features and enhanced security. Always use to the latest version.
    Never download this from any other provider. All links must be from these forums or directly from our server. This is to ensure that nothing was tampered with and that you have the most reliable and tested stuff.

    This Update Includes:
    • Fixes an issue where the main Recovery Patcher script inside the installer doesn't read as UNIX causing the installation to fail.
    • Addresses an issue where Recovery Patcher doesn't add all board ids to PlatformSupport.plist
    • Added Option to make Full Patch OS X Installer as Recovery HD in Recovery Patcher (For Script work Reference / Not functional yet)
    • Adds Support for Mac Pro 1,1 and 2,1
    • Addresses an issue where Graphics Disabler would sometimes fail installation even though it actually performed the tasks.
    • Fixes an Issue where some Macs failed to install AirDrop Enabler
    • Adds Font Changer 1.0 with support for San Fransisco.
    • Updated OS X Hackers App for preparation.
    • Fixed Issue where some Macs fail to install due to current RAM configuration.
    • Automated Kext Installers
    • NoSleep is now a standalone Beta Kext
    • New Installer Feature to allow people who already been successful with installation of OS X 10.9 - 10.11 to upgrade patch files without the need of OS X Installer App.
    • New Hidden Developers Folder for reference/editing of scripts.
    • No More Disappear App in future builds due to language issue. We have our own Hidden File Toggle to be installed in the Finder.
    • Added Beta USB, Bluetooth, and Ethernet Kexts for El Capitan (for Intel ICH7-M chipset models)
    Other features added in Previous Betas:
    • **Support for rendering files in Public Beta Installer.**
    • Bug Fixes
    • Added OS X Recovery Patcher Beta 1
    • Fixed missing Boot.efi Issue
    • Added 10.11 Kernel and OSInstall.mpkg
    • Maintenance, Graphics Disabler, and AirDrop Scripts are now within Installers
    • Removed XPostFactor due to lack of Support and Users
    • Addresses Issue where some El Capitan and Yosemite is greyed out for some users (make sure installer is in your Applications Folder)
    • Fixed Developer link in the ReadMe section.
    • Fixed inaccurate French language for some words.
    • Support for OS X 10.11 El Capitan
    • New Structure with Installer
    • Smarter Requirements Checker that can detect the OS X Installer App
    • More Comprehensive Installation Type
    • Smaller Installer Size
    • Bug Fixes
    Developer Focus Area:
    • Installing OS X El Capitan Beta
    • Kexts
    • General Reliability
    • Rootless Disabling


    Download Size: . . .

    Prerequisites
    Tested Macs listed below. Here are the minimum requirements:
    - Running 10.7 Lion
    - At least 2GB of RAM.
    - A copy of Yosemite or Mavericks in Applications Folder (.app file preferred)
    - 15 GB of free space from USB or HDD Partition.


    -MacBook2,x
    -MacBook3,x
    -MacBook4,x
    -MacBookPro2,x
    -MacBookAir1,1
    -MacMini1,x (C2D upgraded)
    -MacMini2,x
    -iMac4,x (C2D can be upgraded)
    -iMac5,x


    We DON'T assist with Hackintosh. All private messages/emails involving installing OS X on non-Apple hardware will be redirected to another support team.


    How to Use It:
    1. Download OS X Extractor
    2. Install it. Choose a version of OS X to get the correct patches.
    3. Open OS X Hackers in your Applications and view to corresponding guide the OS you choose. (Use Post 1 right now)

     
  23. Adamscomputerrepair macrumors 6502

    Adamscomputerrepair

    Joined:
    Aug 9, 2015
    #123


    I have a MacBook 4,1. I've installed all patches to the installer, put the new kexts in, and everything. Booted it up, I have no mouse, no keyboard, no USB support. What am I doing wrong?
     
  24. atvusr, Aug 10, 2015
    Last edited: Aug 10, 2015

    atvusr macrumors 6502

    atvusr

    Joined:
    Apr 5, 2010
    #124
    Probably nothing. Kext Utility 2.6.4 doesn't work with OSX 10.11 PB4 - it cannot make Backups of the existing Kexts (the /System/Library/Extensions folder is now protected) and therefore it cannot copy the spare Kexts. If I try to add the Kexts manually, I get a Kernel Panic ....
     
  25. Adamscomputerrepair macrumors 6502

    Adamscomputerrepair

    Joined:
    Aug 9, 2015
    #125

    At least you have El Cap running. I can't even get the frickin installer to work.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page