Resolved OS X Yosemite on Unsupported Macs [Guide]

Discussion in 'OS X Yosemite (10.10)' started by TMRJIJ, Aug 3, 2014.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. parrotgeek1 macrumors 6502

    Joined:
    Jun 14, 2016
    Location:
    CA, USA
    #1426
    This also happens with the Nvidia ones (which you spelled wrong, btw).

    Also if you use the Nvidia kexts from 10.6.2 combo update, they actually work, unlike these
     
  2. TMRJIJ thread starter macrumors 68030

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #1427
    Okay. I try those from the combo update for both drivers.

    Also, D’oh :confused:
     
  3. iv22 macrumors newbie

    Joined:
    Aug 3, 2017
    #1428

    How did you done it? I have the same Imac 2006 but it doesn't work. I coudn't start the boot disk.
     
  4. macis macrumors newbie

    macis

    Joined:
    Jul 28, 2017
    #1429
    MacPostFactor 2.0.1 worked for me. There was a problem with El Capitan, but Yosemite installed with no issues. I did as the manual says, and installed from one partition to another empty partition with no USB sticks etc.
    If you're planning to use third-party apps (e.g. Google Chrome or Spotify) I don't recommend to move to Yosemite, because they really do not work due to OpenGL issues.
     
  5. Frustrated123, Aug 5, 2017
    Last edited: Aug 7, 2017
  6. Zedelghem, Aug 17, 2017
    Last edited: Aug 17, 2017

    Zedelghem macrumors newbie

    Joined:
    Aug 17, 2017
    #1431
    Hi! I've got a little story to share.

    So I bought this super cheap old Mac Mini 2006/7 (chassis says '06, internals '07). It was fitted with 4GB of RAM (all detected), Core2Duo 1,83Ghz, Intel GMA950 and ran Snow Leopard (EFI already upgraded and showed MacMini2,1). I put Lion onto it in no time. Frankly, I would be perfectly happy with 10.7.5 if only I could get a modern browser and Ulysses running. Unfortunately, that is not the case. So I tried with El Capitan and it managed to boot (even though none of the above methods worked for me; I used another Mac to install and restore) but run into the yet unsolved USB issue. Then Yosemite it had to be.

    Again, installed Yosemite on a USB with another Mac, restored that USB to a partition on Mini, patched it with SFOTT and... it booted. USB worked like a charm. Cool. Configured, created an account and... crash. Tried again, got me back to the configuration screen. I went through all of it again (it remembered the account I made before but I still had to create a new one) and this time, miracle!, login screen loaded. Alas, this is the end of good news. As soon as I enter the password and try to login it crashes, every time I try - no miracles this time.

    I suspect it must have something to do with GMA950 (cursor is lagging, the screen flashes with grey bars occasionally). Unfortunately I had no luck so far to get OS X Hackers' kexts installed. The .pkg file they provided can't be targeted to any other partition than the current one and I am not learned enough to unravel it, extract what I need and inject it back to the Yosemite drive. (KextsBeast from tonymacx82 couldn't do the targeting either). I will try to do the same trick as with making of the installation drive (install kexts on the USB from another Mac and restore to Mini) but I doubt it will work. After all, to get to the macosExtractor installation stage I need to configure the Yosemite installation and it will then point to a completely different machine. Maybe SFOTT can fix it, I'll keep you posted. If not, then I am back to Lion, I guess. I hope there is still at least one decent browser out there and a markdown-compatible text editor.

    All best and good luck to you all!
     
  7. Benkkuli macrumors newbie

    Benkkuli

    Joined:
    Aug 20, 2017
    #1432
    Hi!
    I just tried creating a bootable media first with macOS extractor but newer got my machine to boot. It just started pouring text all over the screen and then it just went to a reboot loop. With macpostfactor I had even less luck, since it didn't even create the media for some reason. There was always error -1. Then I decided to try SFOTT and that worked. The drive created perfectly and I was able to boot to the installer however, the installer always says that "Yosemite has already been installed on this computer". I haven't been able to find a single thread explaining why would this happen. So I'm stuck right here with my Macbook 2,1 core 2 duo gma950 with 3 gigs of ram.

    Benjami Lindqvist
     
  8. hiroshi.rio macrumors newbie

    hiroshi.rio

    Joined:
    Sep 8, 2017
    Location:
    Rio de Janeiro - Brazil
    #1433
    Hi there. Does anyone have this issue? I can't see the images but I can change them.
    I've tried to disable "transparency" (Accessibility menu) but no success.

    [​IMG]
     
  9. TMRJIJ thread starter macrumors 68030

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #1434
    This is a normal issue due to lack of OpenGL support.
     
  10. terpinator macrumors newbie

    Joined:
    Sep 22, 2017
    #1435
    After using MacPostFactor with "Install Small Recovery" unchecked, and after its first reboot, it's now stuck in a boot loop of "Creating MacPostFactor Recovery" and never going into the OS.

    The machine I'm working on is a Mac Mini 2,1 (Mid-2007).
    What should I do? I didn't clone the disk before and tried this on the main partition.
     
  11. vmk macrumors newbie

    Joined:
    Apr 26, 2017
    #1436
    Had exactly the same problem. According to the logs most kexts were omitted. Also I couldn't find any USB-kexts anymore. So this is how I fixed it:

    First I fabricated a com.apple.Boot.plist with the -no-compat-check flag and copied it to the correct folder. See method 3 for Capitan for instructions. Strangely that file didn't already exist.

    Afterwards I copied all the OS X Extractor USB kexts to my Kexts-folder. Repaired their ownership and then rebooted my Mac. So no cache compiling necessary. When booting in Verbose mode I can see that wrong signatures are now skipped instead of the kexts being omitted.

    Boots fine and quite quick now. Yosemite seems to be somewhat faster as my old Mountain Lion installation. If now only the waking up from sleep issue was fixed..
     
  12. Gpl, Nov 3, 2017
    Last edited: Nov 30, 2017

    Gpl macrumors newbie

    Joined:
    Jan 13, 2017
    #1437
    Any news for a new version of MacPostFactor ?
    I'm not able to get run un imac 2006, i have the video card problem with mavericks and with yosemite i have to remove a ram block to make it work
     
  13. kshane9 macrumors newbie

    Joined:
    Nov 28, 2017
    #1438
    I'm running 10.10.5 on my MacBook 4,1 (early 2008) with the X3100 and AppleHDA kexts. When I plug in my Apogee Jam (USB), the device is not recognized in Audio Inputs. However, the device is listed in System Information - USB.

    Any ideas how to get this USB device recognized as an audio input?
     
  14. snahfu macrumors newbie

    Joined:
    Apr 9, 2015
    #1439
    I have a late2006 imac (upgraded to a ssd and 3gbs of ram)

    Im currently running mlpostfactor with mountain lion installed and it runs pretty great. Very smooth for basic use such as web browsing and youtubing. I was just curious, will installing mavericks, yosemite, or el capitan give me any performance decrease?
     
  15. Gpl macrumors newbie

    Joined:
    Jan 13, 2017
    #1440
    I have your same configuration but i wasn't able to run mavericks or yosemite, ram with good performance, for make it work i have to ramove one ram (i have 2x2Gb) and there is a problem with video card, so graphics performance are not good for me.
     
  16. snahfu macrumors newbie

    Joined:
    Apr 9, 2015
    #1441
    thank you man

    saved me a bunch of time. thank you!
     
  17. wolf1734 macrumors member

    wolf1734

    Joined:
    Nov 9, 2014
    Location:
    France
    #1442
    Bonjour
    Je viens vers vous parce que quand je tries (essais) à installer (Settle) yosemite sur macbook avec Macposfator il (elle) ne fonctionne pas , il (elle) écrire "URL Adify aren » t initialisés! Connexion Internet s'il vous plaît vérifier votre! Macposfactor wil quitter ». Peut me utiliser pour l'installation. Merci beaucoup
     
  18. MacLeodC2D, Jan 1, 2018
    Last edited: Jan 1, 2018

    MacLeodC2D macrumors newbie

    MacLeodC2D

    Joined:
    Jan 1, 2018
    #1443
    @Boosted98 With my limited experience of this, I’ve been trying to get Yosemite installed and working well enough and , to be workable. One thing I did to mitigate login, was at the login screen after first boot, once It’s hung for a while, force your Mac off and re-boot. Do this twice more and the third time of asking you need to wait, OS X will prompt you with a dialog box about reopening apps or something like that, click cancel. You should now be on your desktop, from there you can navigate to settlings and switch on auto login hope this helps.
     
  19. wolf1734 macrumors member

    wolf1734

    Joined:
    Nov 9, 2014
    Location:
    France
    #1444
    hello i just installed yosemite on macbook white 3.1 with mplf 1.0.1 but i would like to know how to update yosemite 10.10.5 thank you for your help
     
  20. olesolo macrumors newbie

    olesolo

    Joined:
    Jan 16, 2018
    #1445
    I wonder any chance to update iMac mid 2006 1,83 (G950), 2Gb of RAM to OSX 10.9? Is it possible? Thanks
     
  21. MacLeodC2D macrumors newbie

    MacLeodC2D

    Joined:
    Jan 1, 2018
    #1446
    It should be, I had 10.10 on a late 2006 IMAC 24” although I’d say the iMac of that period seem particularly fickle in installations. The one I have has the nvidia chip which is rubbish for support, I’d much rather it was Ati.
     
  22. SoldatZack macrumors newbie

    SoldatZack

    Joined:
    Feb 2, 2018
    #1447
    Hay there,

    ok i have a MacBookAir 1,1 and installed with "macOS Extractor" Yosemite on it.
    Wenn i will boot Yosemite it shows me a circle for "unsopported OS"
    What can i do?
     
  23. MacLeodC2D macrumors newbie

    MacLeodC2D

    Joined:
    Jan 1, 2018
    #1448
    It sounds as if you need to update the supported board plist file in core services and the same file in a recovery folder in the same core services location. You can do it via terminal if you know the terminal language to use, or use another mac if you have one and connect the laptop in target disk mode. There will be info in this thread if you search on instructions, you can also temp delet the file using terminal, from a recovery partion or install USB, and add the board plist file later that you have added your board id to.
     
  24. patent10021 macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #1449
    Hi

    I can't seem to find any info on Yosemite hack support for the late 2006 white MacBook.

    I installed OS X 10.9 Mavericks and an SSD on this little guy and this machine is a beast. Everything is perfect. Seems as fast as a new MBA. Only Safari glitches a bit and the audio settings are sometimes strange. But other than that it's awesome. I just use Firefox instead. Weird that Firefox would be fine but not Safari.

    Anyway, I'd love to be able to install Yosemite on this machine. Probably not possible because of the old integrated GPU right?
     
  25. netsrot39 macrumors newbie

    Joined:
    Feb 7, 2018
    Location:
    Austria
    #1450
    Hello guys,
    first of all I want to thank everbody who has made the install of a modern operating system possible on an old MacBook. I recently got a MacBook 4.1 for really cheap and made it pretty much brandnew (new SSD, new RAM, new display, new keyboard, ...) OSX 10.7.5 works really fast on it, however after some research I found this thread and installed OSX 10.10.5 via MacPostFactor which really worked without any problems. Audio and the recognition of the graphics chip didn't work out of the box but I fixed this via some kext files. Only thing that does not work is adjusting the brightness and hibernation mode but I can bypass that by booting into 10.7.5 (I have dual boot system).

    Problem 1: Is there a fix for adjusting the brightness and enabling hibernation? Maybe some working kext-files? (I've read many pages of this thread but didn't find any resolution for this particular problem ...)

    Problem 2: AND IT'S A BIG ONE – Video files don't play smoothly, in other words, very choppy so that it is unwatchable. I've tried NicePlayer and Vuze HD Player, it works (video+audio) but I can't get it to play properly. I think it has to do with the Intel GMA X3100 144MB graphics chip (I know about the 32, 64-bit issue). Is there any way to fix this so I can at least watch some avi files with XviD and DivX Codec smoothly? MKVs play even worse ...

    Maybe I should point out that Youtube-Videos play without any problems in Safari (even 720p)

    Many thanks for any suggestions!
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page