Carrier "Searching..." on my Sprint iPhone 6 (PLEASE HELP)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Bob Parker, Aug 3, 2017.

  1. Bob Parker macrumors newbie

    Bob Parker

    Joined:
    Aug 3, 2017
    #1
    I have been on vacation to Europe for 5 weeks, and I have just returned. Before the vacation, I turned my cellular data off, because I wasn't looking to bust the bank in order to use my phone. Throughout the vacation, my phone always said "Searching..." at the top left. As soon as I arrived at the JFK International Airport in New York, I turned my cellular data on, but my phone still says "Searching..." and even "No Service." As of right now, my iPhone still says "Searching..." and I cannot make phone calls nor connect to LTE (which I have turned on). I have tried every method I could find on the internet, but with no success. I would really appreciate it if any of you guys could help me. Thank you in advance.;) By the way, I use Sprint...
     

    Attached Files:

  2. Bob Parker thread starter macrumors newbie

    Bob Parker

    Joined:
    Aug 3, 2017
    #2
    PLEASE HELP!!!!!!!!!!!!!!!
    --- Post Merged, Aug 3, 2017 ---
    No one wants to help me? :(
     
  3. Audit13 macrumors 6502a

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #3
    I assume you have tried restarting your phone and calling sprint too ensure there are no problems with the carrier network.
     
  4. Bob Parker thread starter macrumors newbie

    Bob Parker

    Joined:
    Aug 3, 2017
    #4
    Yes I have.
     
  5. Audit13 macrumors 6502a

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #5
    And the IMEI is not blacklisted for some reason?
     
  6. Bob Parker thread starter macrumors newbie

    Bob Parker

    Joined:
    Aug 3, 2017
    #6
    It's not blacklisted.
    --- Post Merged, Aug 3, 2017 ---
    The IMEI shows on Settings --> General --> About
     
  7. Audit13 macrumors 6502a

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #7
    You compared the imei to the national blacklist or on swappa.
     
  8. jetsam macrumors 6502

    Joined:
    Jul 28, 2015
    #8
    Turning off cellular data doesn't turn off cellular phone service. Your phone should have found a roaming carrier in Europe, unless you explicitly had international roaming turned off. If you had "Searching..." showing all the time you were in Europe, your phone has been having problems for quite some time.

    I assume your phone is legitimately purchased, and your Sprint account is in good standing. Therefore, I'd try this, in increasing order of severity:

    1) Remove your SIM card from the phone and re-insert it. If this doesn't fix it, then...
    2) Go to a Sprint corporate store. Tell them about the issue you're having, and ask them to replace your SIM card. If they can't get your phone working, then...
    3) Take the phone to Apple for repair or replacement.

    BTW, Sprint now offers free 2G data in most (all?) of Europe, so there was no reason to turn off cellular data. See:
    https://www.sprint.com/en/support/solutions/international/faqs-about-sprint-global-roaming.html
     
  9. Bob Parker, Aug 3, 2017
    Last edited: Aug 3, 2017

    Bob Parker thread starter macrumors newbie

    Bob Parker

    Joined:
    Aug 3, 2017
    #9
    Thank you. I think I'm just going to purchase a new SIM card.
    --- Post Merged, Aug 3, 2017 ---
    I turned off cellular data, because I was visiting Kosovo, which is a partially recognized state, and I didn't think Sprint would cover it.
    --- Post Merged, Aug 3, 2017 ---
    I checked on Swappa.
     
  10. jetsam macrumors 6502

    Joined:
    Jul 28, 2015
    #10
    A Sprint rate check says $15/MB for Kosovo, so I guess you did the right thing. ;)
     
  11. Bob Parker thread starter macrumors newbie

    Bob Parker

    Joined:
    Aug 3, 2017
    #11
    Yep! :)
     

Share This Page