Some Mac App Store Apps 'Damaged' Due to Expired Security Certificate

Discussion in 'MacRumors.com News Discussion' started by MacRumors, Nov 12, 2015.

  1. Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #51
    It just **doesn't** work!

    I'm still on Yosemite for other issues with El Capitan..

    This reminds me when Apple shipped iPhoto on Macs and it wouldn't open,,, 24 hours later they released an update to fix the problem.
     
  2. b.inazawa-fan macrumors member

    Joined:
    Apr 2, 2013
    Location:
    Michigan
    #52
    https://twitter.com/tapbot_paul/status/664822849534754816
    Yep, looks like Tweetbot on 10.9 is toast.

    It was on an old machine that runs faster with older OSs. 10.9 was the oldest viable version until this, I've upgraded it to 10.10 now.

    No, but some apps must have a valid certificate to launch. Certificates expire, but (they're supposed to) get updated with app updates. If you'd never update your apps again, the next time this will happen is in 2017, from the new certs.
     
  3. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #53
    Oops... must have hit a nerve :D
     
  4. SmallDane macrumors member

    SmallDane

    Joined:
    Dec 23, 2014
    Location:
    Denmark
    #54
    So what happens if a purchased app is no longer available on the MAS? As mentioned above I could not get Screenium to work even after a complete re-install of El Capitan. I notice that the version of Screenium that I have purchased is no longer available for new purchases. Perhaps that is why nothing helped.
     
  5. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #55
    Damn, just noticed I cannot open 1password because it says damaged. Wonder how many more are damaged that I have not tried to open. Big pita as it says to uninstall and redownload.

    I own a mac and ipad but I dumped my iphone for a moto x pure, won't be going back.
     
  6. OLDCODGER macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #56
    Thank you very much for your reply. Thank goodness for Little Snitch, should I ever buy from MAS.
     
  7. granlaras macrumors newbie

    Joined:
    Jun 16, 2011
    #57
    Happen to me this morning launching "Billings", I thought I did something wrong! and was going crazy all day, because I couldnt review all the bills I sent to clients, and I needed to send an invoice today...
    I did all I could to make it work, uninstall the app, reinstall it. even booted OSX from a copy I had from 2014, but the app said the same with over an over, "that it was corrupt".
    I tried login out and login in from the store, but nothing works. App is dead.
    There is no solution for this?
    My company is run with this app. Without it, I cant send bills or check the invoice I sent, or invoices that havent been payed... It would take me ages to move everything somewhere else! :(
     
  8. Razeus macrumors 603

    Joined:
    Jul 11, 2008
    #58
    Welcome to Tim Cook's Apple...

    It Just Works is a thing of the past.
     
  9. PJWilkin macrumors regular

    Joined:
    Jun 24, 2010
    #59
    I had the same issues, even a reboot would not fix. I had to sign in (as it requested) to fix.

    Apple probably have some big issues somewhere (I know someone has posted here about the certificate expiring on an app). Not good either way
     
  10. heeloliver macrumors 6502a

    heeloliver

    Joined:
    Sep 6, 2014
    Location:
    Santa Cruz, CA, USA
    #60
    El Cap is 100% not beta quality. Yosemite, maybe, but El Cap is smooth and reliable, like Snow Leopard
     
  11. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #61
    Seems like a big issue to people who need to run those apps but cannot.

    I don't know if its a El Cap issue, or something on the App Store side of things.
     
  12. FieldingMellish Suspended

    Joined:
    Jun 20, 2010
    #62
    I'm concerned that I've been forced to use Outlook for email, now that El Capitan has killed my ability to use Apple's Mail.

    I thought an Apple Genius would help me get it fixed and there was nothing he was able to do.
     
  13. MVallee macrumors 6502a

    MVallee

    Joined:
    Feb 8, 2007
    Location:
    Ontario, Canada
    #63
    1Password is working fine for me, but last night it did ask me to enter my Apple ID password before it would open.
     
  14. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #65
    I had to uninstall 1password and reinstall, now it opens but cannot get in to enter password. When I click a.t the bottom of the page it crashes.

    The new apple. We charge more for less, solder everything in and it doesn't just work.
     
  15. arpi macrumors newbie

    arpi

    Joined:
    Feb 25, 2014
    #66
    Maybe on some machines it's stable. On older ones (like 2013 iMac) bluetooth has 6feet range, app hangs, etc. Also check the reviews on the app store, especially the recent ones.
     
  16. TMRJIJ macrumors 68040

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #67
    iStudiez Pro just asked for my Apple ID and password. After which it opened normally.
     
  17. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #68
    To be honest, I prefer not using the MAS whenever I can. Many apps have less features because of Apple's sandboxing and security requirements.

    So far, I'm happy to say this issue hasn't bitten me.
     
  18. OldSchoolMacGuy Suspended

    OldSchoolMacGuy

    Joined:
    Jul 10, 2008
  19. Thunderhawks Suspended

    Joined:
    Feb 17, 2009
    #70
    While I had a template classified as "damaged" in Excel, I managed to survive.

    Maybe the sky IS falling. If you paid for El Capitan you got fleeced.

    Newsflash: The world is not perfect and Apple's brand image is just fine.

    Disk Utilities> First Aid> Restart would be my first advice.
     
  20. Elbon macrumors 6502a

    Elbon

    Joined:
    Jan 9, 2008
    Location:
    Boston, MA
    #71
    I've been having trouble updating Xcode all morning. And this isn't the first time. The App Store app has always been a bit unstable for me, but recently it has gotten much worse. Updates take forever to install, and then fail with a vague "unknown error occurred" message. I finally filed a bug about it yesterday.
     
  21. lysingur macrumors regular

    lysingur

    Joined:
    Dec 30, 2013
    #72
    I'm actually kind of glad that Apple isn't planning on making any cars. Oh, wait...
     
  22. rochow macrumors member

    Joined:
    Aug 20, 2013
    #73
    Phew, it's not just me! Heart attack earlier when a number of my apps wouldn't open.

    I'm too scared to "delete it, then re-install". Will it lose all my settings...? I don't want to find this out the hard way.

    Seems like a lazy bug. "Oh there's a problem. Yeah we couldn't be bothered trying to resolve it, just wipe it all and start fresh".
     
  23. superkatalog macrumors regular

    Joined:
    Jan 7, 2002
    Location:
    switzerland
    #74
    same here with billings!
     
  24. skellener macrumors 68000

    skellener

    Joined:
    Jun 23, 2003
    Location:
    So. Cal.
    #75
    Probably not related, but I haven't been able to launch Pages or Numbers (Mac App Store versions) even since I installed Yosemite. Deleted and downloaded many times. Nothing. They worked fine before that. My old iWork installs (the old versions) still work just fine. Has this ever been fixed?
     

Share This Page