Who has the Notes sync issue?

Discussion in 'iOS 10' started by realpras, Jan 18, 2017.

  1. realpras macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #1
    I've browsed the forum and it seems some people also have this issue, but I just want to know your opinion about this and if you've solved the issue.

    Notes do not sync when it's created from the Notes app on both my iPhone and Mac. The existing notes will load just fine but when I make a new note/make changes to existing notes, it doesn't sync to the other device/icloud.com on the web.

    However, interestingly, if I make a new note/make changes from icloud.com on the web, it will sync down to both devices.

    I tried signing out/in of my iCloud account, resetting the devices, turning off/on Notes on the Apple ID to no avail. Other apps sync just fine, it's just Notes that has been wonky since I don't know when.

    Anyone have this issue and found a fix without involving Terminal? Did you know if this is fixed in the upcoming iOS 10.2.1 or macOS 12.2.3?

    Thank you.
     
  2. foxconn Suspended

    Joined:
    Sep 6, 2016
    Location:
    www
    #2
    I fixed it. Check the thread I made someone showed a solution

    For iOS you gotta log out of iCloud and delete the notes app. And then reinstall from App Store. Just backup your notes cause they'll all be erased.

    For the computer you need to enable developer mode and click some things in the debug menu.

    It's been working since.
     
  3. realpras thread starter macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #3
    I think I saw it somewhere before but I want to avoid fiddling with it as best as I can. However, can you please link me to the actual post so I can see it again? I've tried to find it but I couldn't. Thank you.
     
  4. foxconn Suspended

    Joined:
    Sep 6, 2016
    Location:
    www
    #4
    [EDIT2] MAKE SURE YOU HAVE A BACKUP OF YOUR NOTES!! IT MAY DELETE ALL OF THEM…

    Hello guys,

    I have a similar issue, where my notes were not synced between my devices. At least, it was only working one-way, from iCloud to my devices, but not the other way.
    I *may* have found a solution, at least, now it seems to work between my iMac, and iCloud, but it is still erratic with my iOS devices.
    Here is how I proceeded:

    1) activate the « on my Mac » account in Notes on your Mac,
    2) move all your notes from the iCloud account to this new « on my Mac »,
    3) quit Notes,
    4) launch the Terminal application, and enter the following command:
    defaults write com.apple.Notes DebugModeEnabled -bool true
    5) launch Notes, and make sure that there is no notes in the iCloud account,
    6) a new « Debug » menu appeared in the application; choose « Delete Data (Delete from Cloud) »,
    7) quit Notes, and in the terminal, enter the command:
    defaults delete com.apple.Notes DebugModeEnabled
    8) launch Notes again (the Debug menu has disappeared), and create a new note in the iCloud account,
    9) with Safari, connect to https://www.icloud.com/, and check if your note has been uploaded,
    10) modify the note on the iCloud website, and check the Notes application behaviour,
    11) if the application seems to work properly, move your old notes from the « on my Mac » account to the iCloud account.



    Trust me it seems like a lot of work. But it's not. Backup your notes!!

    For iOS just delete the notes app and it will work.

    I did this last week and no issues since.
     
  5. realpras, Jan 18, 2017
    Last edited: Jan 18, 2017

    realpras thread starter macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #5
    I just tried this but it didn't work on the Mac. It syncs down but does not sync up. However, the iOS one now works by simply deleting the app and reinstall again. Any idea on the Mac one?

    EDIT: I finally managed to make it work, so in addition to Delete Data (Delete from Cloud), I clicked on other options too and it finally worked between icloud.com and each device. Thank you for your help, I hope this is fixed permanently!
     
  6. foxconn Suspended

    Joined:
    Sep 6, 2016
    Location:
    www
    #6

    Glad it worked for you.
     
  7. supermars macrumors newbie

    supermars

    Joined:
    Dec 1, 2015
    #7
    Same problem here, but only with iOS (the latest one); on mac everything is fine.
    NO SOLUTION from Apple assistance after 5 hours of testing different ways and some notes are lost now.
    Terrible :-/
     
  8. realpras thread starter macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #8
    If it's on iOS, simply delete the app then get it again from the App Store. That fixes it for me.
     

Share This Page