Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 65816
Apr 22, 2010
It was a known issue for the S4 owners and there's a thread here discussing it.
Yeah I know. My S3 hasn’t been able to update either because it would fail to verify because it said I wasn’t connected to the internet. I was able to update with 7.2 though after a couple of download failures.


macrumors member
Aug 26, 2010
ECG app is now at version 2.18S563.

watchOS 5.1.2: ECG app v1.1 (initial US release)
watchOS 5.1.3: ECG app v1.2
watchOS 5.2.0: ECG app v1.10 (now available in Europe and Hong Kong)
watchOS 5.2.1: ECG app v1.13 (additional European countries)
watchOS 5.3.0: ECG app v1.18 (now available in Canada and Singapore)
watchOS 5.3.1: ECG app v1.18
watchOS 6.0.0: ECG app v1.30
watchOS 6.0.1: ECG app v1.30
watchOS 6.1.0: ECG app v1.50
watchOS 6.1.1: ECG app v1.51
watchOS 6.1.2: ECG app v1.51
watchOS 6.2.0: ECG app v1.70 (now available in Chile, New Zealand, and Turkey)
watchOS 6.2.1: ECG app v1.70
watchOS 6.2.5: ECG app v1.80 (now available in Saudi Arabia)
watchOS 6.2.6: ECG app v1.80
watchOS 6.2.8: ECG app v1.90 (now available in Bahrain, Brazil, and South Africa)
watchOS 7.0.0: ECG app v1.18R395 (now available in Colombia, Israel, Kuwait, Oman, Qatar, and United Arab Emirates)
watchOS 7.0.1: ECG app v1.18R395
watchOS 7.0.2: ECG app v1.18R402 (Resolves an issue that prevented some users from accessing the ECG app in regions where it is available)
watchOS 7.1.0: ECG app v1.18R590 (now available in Republic of Korea and Russia)
watchOS 7.2.0: ECG app v2.18S563 (now available in Taiwan. Atrial fibrillation classification at heart rates above 100 BPM now offered in the ECG app in most regions where the app is available)
Last edited:


macrumors member
Jul 20, 2011
I'm having a really hard time installing updates on my S3 lately. I tried to install 7.1 when it came out and my watch had only 2GB free space (of 4GB total). I uninstalled all apps I could and didn't have any other content on it (music, photos, etc). I finally had to reset the watch and set it up again to get 7.1 to install.

Today I tried to do 7.2 but had the same issue (only 2GB free, the update required 2.5GB free). Again, this is with no content on the watch and only the stock apps installed. I was finally able to get 2.2GB freed up and it looks like the install is progressing now.

I don't know why I have 4GB capacity but only 2GB free right off the bat with setting the watch up with my iPhone. Hopefully the install goes thru so I can use Fitness + tonight.
Same problem with my wife’s S3. I have to Unpair and Repair before every update. It’s pretty ridiculous.

I miss the good ol days when Apple products “just worked”.


Mar 22, 2009
Installed just fine, but Apple Pay stopped working. I didn't realize that until I tried to buy some groceries and my credit card failed to show up.

Luckily I had my iPhone with me and payed with it just fine. Not sure whether the culprit is WatchOS 7.2 or my bank app.
  • Sad
Reactions: katbel


macrumors 6502a
Apr 12, 2002
I do notice one thing after the upgrade - my battery usage has gone way down. Only used 30% of my power all day. Now its easy to keep it on for sleep tracking.


macrumors 6502a
Apr 12, 2002
Same problem with my wife’s S3. I have to Unpair and Repair before every update. It’s pretty ridiculous.

I miss the good ol days when Apple products “just worked”.
Yeah but the base 6 has 32Gigs of RAM. I finally took the plunge and got the 6, the 3 might be able to run 7.2 but it doesn't like it.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.