iOS 11 and CarPlay issues?

Discussion in 'iOS 11' started by Mike84, Sep 21, 2017.

Tags:
  1. CTHarrryH macrumors 68000

    Joined:
    Jul 4, 2012
    #76
    I have found, and I'm not sure this is IOS 11 related but when I plug my phone in to use CarPlay it doesn't record any of my destinations in the Significant locations (use to be frequent locations). I use CarPlay a lot more in IOS 11 so I don't know if this is IOS 11 related or? No places that I went to with phone plugged into CarPlay are recorded now in significant locations.
    Anyone else notice this?
     
  2. macfacts macrumors 68030

    macfacts

    Joined:
    Oct 7, 2012
    Location:
    Cybertron
    #77
    Apple shouldn't let them advertise them as CarPlay compatible then. It is ruining Apple's image, as shown by this thread.
     
  3. BorderingOn macrumors 6502

    Joined:
    Jun 12, 2016
    Location:
    BaseCamp Pro
    #78
    Seems like folks are having some different experiences with IOS 11. I'll check in to say 11.0.3 broke CarPlay for me. Car would charge the phone but not recognize it as a CarPlay device. The iPod function continued to work if I opted for that. I use CarPlay for my navigation so I decided to try the public beta and CarPlay was again working fine.

    The idea that auto manufacturers need to update their software when Apple updates IOS is ridiculous. Think of the logistics. Since CarPlay specs were defined and handed to OEMs, compatibility should not change with IOS updates, ever, unless perhaps Apple decides to make CarPlay 2 or some major rework of it.
     
  4. rellimie macrumors member

    Joined:
    Apr 30, 2010
    #79
    Just checking in. iOS 11 completely borked CarPlay in my 2017 Honda Ridgeline. Random disconnects and sometimes will play audio from several different apps simultaneously. Really pissed.
     
  5. CTHarrryH macrumors 68000

    Joined:
    Jul 4, 2012
    #80
    I suspect that as in all software the software and hardware in cars isn't perfect and if they didn't fully and completely follow Apple requirements bugs will happen. Haven't checked any Android Auto forums but I suspect people are having the same problems with the same cars.
     
  6. jettie1767 macrumors 6502

    Joined:
    Oct 29, 2003
    Location:
    New Jersey, USA
    #81
    I have no issues with IOS 11.1 beta 4 and CarPlay on both my BMW 530e and X6M. My overall experience with CarPlay and BMW has been very good.
     
  7. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #82
    Have you upgraded your iOS yet? Make any difference? Maybe try the 11.1 beta 4?

    Heh...asking as I'm having one installed into my SUV on Monday. :) If the iPhone 8 is having issues with it, chances are the iPhone X will too.
     
  8. Shippers72 macrumors newbie

    Shippers72

    Joined:
    Oct 22, 2017
    #83
    iOS 11 has made CarPlay unusable. The connection freezes occasionally but worse, the audio continually cuts out - it ranges from almost imperceptible dropouts to cutting out for a second at a time. The only way round it is to power off the phone and back on again.

    My old iPhone 7 on iOS 1 worked perfectly for months. That started showing the issues as soon as it went iOS11 and persisted when I switched to an 8 Plus. The car (BMW) firmware is up to date.

    Seen nothing from Apple and a trip to th Genius Bar was unsurprisingly useless. Anyone else seen the same glitches in audio?
     
  9. stillcrazyman macrumors 68000

    stillcrazyman

    Joined:
    Oct 10, 2014
    Location:
    In Exile
    #84
    I have iOS 11.0.3 on my 7 Plus. I have an aftermarket Pioneer 8201NEX (current firmware). I still have occasional connection issues - phone not recognized, random disconnects. Usually, one reconnect of the USB-Lightning cable on the iPhone will correct the problem. I've tried two other cables with no changes. It's got to be an issue in the iOS.
     
  10. kingston73 macrumors 6502a

    Joined:
    Dec 23, 2015
    #85
    Have any of you tried the latest 11.1 beta 4 with CarPlay? CarPlay is the one reason I’ve stayed on 10, 11 did not work well with my Kenwood.
     
  11. Ubee67 macrumors newbie

    Ubee67

    Joined:
    Oct 29, 2017
    #86
    Turn off bluetooth
    --- Post Merged, Oct 29, 2017 ---
    I have 2017 maxima. Try after turning off Bluetooth.
     
  12. kingston73 macrumors 6502a

    Joined:
    Dec 23, 2015
    #87
    I foolishly updated to beta 5 and regret it. Carplay is working OK but won't update album artwork. Also talking to siri when trying to text people is definitely broken, 10.3.3 understood me very well and now it garbles things and makes it look like I'm drunk texting people. WTF apple, how to break things that used to work?
     
  13. funroe macrumors newbie

    funroe

    Joined:
    Oct 30, 2017
    #88
    I've been having issues with my 2013 Chevy Spark, that only occurs with the new iPhone 8+, my old iPhone 5 worked fine. Now it disconnects every few seconds and reconnects. Super disappointing.
     
  14. Baumer582 macrumors member

    Joined:
    Feb 20, 2008
    #89
    Good news everybody!

    iOS 11.1 Fixed my issues!!

    No problems connecting, and the phone charges in my Maxima.

    Thank you Apple!
     
  15. saketbash macrumors newbie

    Joined:
    Jun 18, 2008
    #90
    Same here - iPhone 7 Plus w/ 11.1 in '17 Maxima - no issues getting CarPlay to work the first time AND I get charging :)
     
  16. joepasc54 macrumors newbie

    Joined:
    Oct 7, 2017
    #91
    --- Post Merged, Nov 2, 2017 ---
    Yes, it doesn't connect the first time. Have to go to general settings carplay forget this car constantly. Music shows play pause button but no music plays when you hit play. Dropped repeat button on amazon music. Text messages have no sound but show they're playing. They should spend less time on driverless technology if they can't get CAR Play right!
     
  17. lwilliams macrumors regular

    lwilliams

    Joined:
    Nov 27, 2012
    Location:
    Athens, GA
    #92
    YES!!!!!!!!!!!! iOS 11.1 solved my issues in my 2018 Ford Escape.

    Well, except for the Sirius Moble app. (Yes, I have Sirius built into the car, but there are a few channels that are "online only". )

    Finally!!!!
     
  18. Damolee macrumors 6502

    Joined:
    Nov 20, 2012
    #93
    Have to say, my Pioneer unit loves iOS 11.

    I no longer have to connect phone > launch Spotify > close Spotify on the handset and launch it again.

    I plug my phone in and off I go. Can launch all songs from the headunit touchscreen for a change.

    I can also use a separate sat nav on the phone (Co-Pilot) without the headunit taking over my phone and shutting it down.
     
  19. Valtool macrumors newbie

    Valtool

    Joined:
    Nov 2, 2017
    #94
    2018 Hyundai Elantra, the audio gets garbled/staticky at random times. Tried 3 different USB cables, happens with all 3. Dealer said try an Apple made USB.

    Anyone else have similar issues?
     
  20. Malcivar macrumors newbie

    Joined:
    Nov 2, 2017
    Location:
    NY
    #95
    I also own a 2017 Maxima and a Iphone 6s. I have the same exact problem. Carplay worked fine under IOS 10. The minute I "upgraded" to 11 I started having the same problems you describe.
     
  21. fitchp macrumors newbie

    Joined:
    Nov 3, 2017
    #96
    My CarPlay was working on my 2018 Acura TLX with version 11.03 (I think that’s what I was using), but I upgraded to 11.1 last night, and was having problems this AM. The CarPlay app started on my phone, and said “loading” on my car screen, then went blank.

    Any advice? This is very frustrating, since I just bought this car less than 2 weeks ago! Thanks
     
  22. roncron macrumors regular

    Joined:
    Aug 15, 2011
    #97
    No problems using Carplay between my 7+ and a 2018 Subaru Outback. Carplay has worked fine since I installed an early public beta of iOS 11 a couple months ago, through every beta and the public releases of 11 and 11.1.
     
  23. hypobid macrumors newbie

    Joined:
    Nov 11, 2012
    #98
    I can confirm that 11.1 resolved the issues I was having with my 2017 Maxima :) All is working perfectly now!
     
  24. Jhizer macrumors newbie

    Joined:
    Nov 4, 2017
    #99
    I am also having issues. I have a 2016 Chevy Colorado. CarPlay will not read or respond to messages and crashes when playing Pandora causing the unit to reboot. I have not tried it with maps yet.
     
  25. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #100
    I have the same problem, 2018 TLX. I deleted the phone from the car, then rebooted the phone and it has started working again. Hopefully that will do it.
    Never had a problem before ios11. Using a 6+.
     

Share This Page