iOS 11 and CarPlay issues?

Discussion in 'iOS 11' started by Mike84, Sep 21, 2017.

Tags:
  1. CTHarrryH macrumors 68000

    Joined:
    Jul 4, 2012
    #101
    I have found that I can't plug in my phone to my car for a bit after the car has started up and been running for a couple of minutes. Most of the time it runs fine anyway but I find it always runs fine when I let the car unit fully start and settle down
     
  2. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #102
    The delete, reboot and reconnect experiment has failed. Worked for music/calls for a day. This morning, I put on maps. It brought me to a choice for directions that I used last week. After trying to dismiss that, the system died and the screen went black.
    I can use Bluetooth for music and calls. Maps is why I wanted CarPlay and didn’t get the built in nav system. This sucks. I should never have updated to 11.
     
  3. kingston73 macrumors 6502a

    Joined:
    Dec 23, 2015
    #103
    For whatever it's worth, 11.2 beta has fixed any issues I had with carplay and it's now working very well with my kenwood.
     
  4. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #104
    How do you get set up with the beta version?
     
  5. kingston73 macrumors 6502a

    Joined:
    Dec 23, 2015
    #105
  6. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #106
    As long as I don’t use maps, the system seems stable. iOS 11 has severely messed up my 6+. I’ll wait for some more updates to see if things get smoothed out. I wasn’t planning on upgrading my phone yet, but I may not have a choice.
     
  7. Bustercrabbe macrumors newbie

    Joined:
    Nov 10, 2017
    #107
    --- Post Merged, Nov 10, 2017 ---
    I’ll tell you what worked for me and my MDX phonebook issue. If you delete all the contact photos from your iPhone contacts the phonebook should work correctly.
     
  8. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #108
    Never had a phonebook problem.
    I'm still having random crashes, not just with maps running. However, my phone is running poorly overall since updating to ios10.
     
  9. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #109
    Problem solved.
    I restored my phone completely and rebuilt from a backup. Haven’t had a crash of CarPlay in over a week.
    iOS 11 is still pretty laggy on my 6+, but that is to be expected.
     
  10. itsemmawithaj macrumors newbie

    itsemmawithaj

    Joined:
    Nov 22, 2017
    #110
    Hey guys, I’ve just updated to 11.1.2 on my 7plus and am now having issues with CarPlay. It connects without any issue and most aspects work but it won’t read out messages, write messages, read out directions with map or give me voice prompts with making calls.

    I thought initially it may have been an issue with siri but I have disabled and enabled it and Siri is working fine outside of CarPlay.

    I’ve reset network settings/the phone itself, changed the cord. Have tried everything I could think of and haven’t seen a post re the same issue so it is starting to do my head in a little.

    In short - CarPlay connects and works except for the voice prompt aspects.

    Any ideas at all?
     
  11. itsemmawithaj macrumors newbie

    itsemmawithaj

    Joined:
    Nov 22, 2017
    #111
    Have the same issue - messages not being read out, can’t write messages and no voice prompts on Maps when looking up an address
     
  12. KrisLord macrumors 65816

    Joined:
    Sep 12, 2008
    Location:
    Northumberland, UK
    #112
    I’m seeing that occasionally on iOS 11.2.

    If you ask to send a text for example, you see the Siri animation but you don’t get told “who would you like to send”
     
  13. Breezygirl macrumors 6502

    Breezygirl

    Joined:
    Oct 7, 2011
    #113
    Mine is working properly the last few days and reading out messages again. Is yours yet?
     
  14. itsemmawithaj macrumors newbie

    itsemmawithaj

    Joined:
    Nov 22, 2017
    #114
    No luck yet! V frustrating
     
  15. brbeaird macrumors newbie

    brbeaird

    Joined:
    Nov 27, 2017
    #115
    2016 Civic here. Have been having intermittent issues with CarPlay since iOS 11. It seems to work initially but if I stop the car to run a short errand come back, about half the time CarPlay either:

    • Shows connected but no audio comes out
    • Works but the screen shows "No device connected"
    • Doesn't connect or work at all

    All 3 issues are solved by rebooting my iPhone 8. Rebooting the car's system does nothing.

    I've updated to 11.1.2 but still seeing these problems.
     
  16. posnera macrumors regular

    Joined:
    Jun 13, 2010
    #116
    And I spoke too soon. Now crashing again almost daily.
    My phone is garbage since updating to iOS 11. I often can't even listen to voicemail without a reboot.
     
  17. DBOC macrumors newbie

    DBOC

    Joined:
    Nov 30, 2017
    #117
    Same here, I can no longer use the SMS read/dictate on my BMW 540. Very frustrating. I also use Spotify and ever since I have issues scrolling down through the menu. I am still hoping for a fix.
     
  18. tromboneaholic macrumors 65816

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #118
    I’m not having any issues with Honda CarPlay since iOS 11.1

    Have you gone into CarPlay settings on the phone and deleted the Honda? Do this while not connected.
    Once you connect it again it will re-pair.

    Also, I deleted Bluetooth devices and turned off Bluetooth. Don’t know if that helped, but I’m not using Bluetooth with CarPlay, so it couldn’t hurt.
     
  19. DBOC macrumors newbie

    DBOC

    Joined:
    Nov 30, 2017
    #119

    So I just attempted something and the issue of reading and dictating SMS via CarPlay was solved: I enabled “press home for Siri” in addition to the previously enabled options. Please see attached.
     

    Attached Files:

  20. Breezygirl macrumors 6502

    Breezygirl

    Joined:
    Oct 7, 2011
    #120
    My CarPlay started to work properly again out of the blue about 2 weeks ago.

    Nice to see yours is working again as well. :)
    --- Post Merged, Nov 30, 2017 ---
    Just to let you know, try the fix posted above this post and see if it helps.
     
  21. AngelL macrumors newbie

    Joined:
    Dec 1, 2017
    #121
    I also have a Ford w/Sync 3, and literally just started having major issues yesterday (I've always had the occasional loss of connectivity, but nothing to write home about). I nearly always use Pandora while in the car, and turn off the phone with it running in the background so that aside from calls that come thru my Bluetooth I will not receive notifications while driving. This has always worked until yesterday. Now, as soon as I turn off the phone or even leave Pandora to go to another app (again, it is still running in the background), it stops playing entirely. I did find my Sync software needs to be updated, so I will be downloading that this weekend to see if it helps the issue, but if not.... :O
     
  22. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #122
    I'd suggest those still having issues to grab iOS 11.2 that was released this morning and if all of your CarPlay issues aren't resolved, get on the beta so you have a mechanism to give this feedback (repeatedly) back to Apple, so these issues get fixed.

    Apple's going to need to do the fixes - they're the ones that are breaking everything.

    https://beta.apple.com/sp/betaprogram/
     
  23. Gingerdog macrumors newbie

    Gingerdog

    Joined:
    Dec 6, 2017
    #123
    --- Post Merged, Dec 6, 2017 ---
    I am having problems with Chevy’s system in a new 2017 model. Never has worked right. iPhone 6s with x11. Chevy just updated OS and stuff is not working well. Reading about this, someone has recommended resetting network settings on iPhone.
     
  24. GoatHerderEd macrumors newbie

    Joined:
    May 16, 2009
    #124
    I'm on iOS 11.2 on an iPhone 6 and have a Ford Fusion 2017 Hybrid Titanium; having Car Play issues as well. Seems to have started in December and possibly after my iOS 11 update (from 10.3).
     
  25. Mark Kamers macrumors newbie

    Mark Kamers

    Joined:
    Jan 3, 2018
    Location:
    Leuven
    #125
    All,

    I have a question related to Carplay and outgoing calls with iPhone8.

    I have CarPlay installed in a Volvo XC90. Software is up to date. I use iPhone 6
    and iPhone 8 with an USB cable.

    When making a phone call with my iPhone 6 (using the Voice commands/Siri) all is OK.
    The number is dialed and the center display is nicely displaying the phone interface AND the microphone is working (= I can talk and people do hear me).

    When I connect the iPhone8 via the same USB cable, I can again make a phone call using the Voice interface or Sir BUT then each time the microphone is on MUTE!. If unmute via the center display of the car or the iPhone, a normal call can be
    held...

    Very awkward since this is NOT the case with the iPhone 6.....

    I looked on the internet to find information on this, but could not find it.

    The 'do not disturb me' function is NOT activated.

    Any clue on what setting on the iPhone 8 needs to be enabled/disabled?


    Thanks,

    Mark
     

Share This Page