Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Michal141

macrumors newbie
Original poster
Oct 22, 2016
2
0
Hi to all,

I have a problem with my iPod Nano 6th generation with sound volume "up" button.

When I plug original Apple Earpods, all is working fine as normally. I can turn volume down and up via remote on headset and also when I press volume buttons on my iPod.

When I unplug headphones, only "down" volume button is working, and when I pressed volume "up" button, it does nothing ! I can increase my volume only via settings menu (which needs a few steps more to do instead of touching simple volume "up" button only).

I think that is not normall situation.. :( Did anyone know why is this button not working without headset ?
Or is that normall funtionality ?

I have tried some solutions from internet:
1) Reflash firmware again - not helped
2) Clear my iPod account in iTunes and reseting device - not helped
3) EU problem with sound limit - not applied in my iPod (max. volume is ok)
4) tested more Apple headsets - all is working fine, until I unplug headphones from iPod. All other brands of headsets have the same problem as unplugged headset (volume up button is still not working on ipod).

...I thought that volume button "up" is not working correctly, but it can be normally pressed and with Apple headset is working good, so it seems that this is not a hardware problem.

When I brought it to service point, they don't know why is this caused, and offered me replacing my iPod for a new one (of course price was as new iPod...) - so its not a solution of my problem :)

Any ideas ? any more solutions are welcome :)

Thank you !
 

Michal141

macrumors newbie
Original poster
Oct 22, 2016
2
0
Thanks for reply Mike B !

I have seen that, but I tried it again recover. Ipod does it with no problems, then iTunes reset device and set up.
Now - my power button works like volume up and shows volume icon, and volume up shows volume control and also turns off the display like power button :) It's a little bit crazy ! :)) I tried 3x recovery process again, but the same results. If I go to N20 snowfox mode, any button does not work (before that works only one button because of volume stucks). But when I need reset the iPod, buttons are visibly working, because it was need to do that...
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.