Issue with iMac SSD upgrade

Discussion in 'iMac' started by RobotMan, Feb 12, 2016.

  1. RobotMan macrumors newbie

    Joined:
    Feb 12, 2016
    #1
    I recently upgraded my mid-2010 27" iMac with a new Samsung 850-Evo SSD and am running into a weird problem.

    The install was easy with the adapter I used from OWC with the thermal sensor, nothing out of the ordinary occurred, no breaks, no broken display cable. SMC and PRAM all reset.

    When I went to install El Capitan was when I first ran into the issue. The install just would not happen, as in, it would get maybe halfway through the install and then the machine would just freeze and restart giving me the white screen of death saying my computer had restarted because of an issue yadda yadda. After a few failed attempts I opened the machine back up and installed El Capitan on the SSD from a third party machine with no issues. I plugged the drive back in the iMac, closed it up and went on setring it up.

    The first time I booted I got a weird kernel panic at the grey screen so I restarted to see if I could reproduce but it rebooted perfectly. Everything was going well for about 20 mins when suddenly the machine froze for a second and then just restarted giving me he same white screen. The iMac boots perfectly and loads the OS but after extensive testing I've found that it's when I install certain programs or spend too long online that it will produce the same error and seemingly restart randomly. Firefox and thunderbird downloaded and installed just fine, Xcode and Microsoft office productivity suite will reboot the machine with an error (the Microsoft productivity suite will reboot just as it gets to writing the package contents). Spending too long online will also cause thenimac to reboot, in fact, thebfirst time I tried to write this post about halfway through the browser slowed down, then I got a few beach balls, then the iMac rebooted with the same error screen telling my to wait or press any key to reboot.

    Putting in he old hard drive does not produce the same issues. Every diagnostic tool I've used says my hardware is working as it should. I've installed Trim and enabled it and am running an AHT now. One thing I did notice is that when I tried to do the Internet service AHT when it connected instead of starting AHT I got an error code of -3403D which I have not been able to get a straight answer about. So instead I downloaded AHT from GitHub and made a bootable USB to use since I no longer had the disks with the test on it.

    I'm running out of ideas and have hit the last of my tricks that I can use to try to figure this out. This was supposed to be a fairly easy upgrade but this issue is driving me crazy. Any help would be much appreciated and if there is any need for more info I'll be glad to provide. Thanks.
     
  2. Dopeyman macrumors 6502a

    Joined:
    Sep 5, 2005
    Location:
    Los Angeles!
    #2
    Might be the SSD itself. I had a somewhat similar problem with a Crucial drive in a macbook pro... It wouldn't fully install captain on it. It would freeze a lil past half ways.

    Try exchanging it the drive from where you purchased it.

    Hope this helps..
     

Share This Page