Mac Pro 4.1 5770 mini display port issue

Discussion in 'Mac Pro' started by Jackdown_101, Feb 28, 2017.

  1. Jackdown_101 macrumors newbie

    Joined:
    Feb 28, 2017
    #1
    Hi all, long time lurker first time poster. I've got a Mac pro 4.1 2.26Ghz that has been flashed with 5.1 firmware.

    The issue is that I've just installed a flashed XFX HD 5770 like this one to use as a back up card and it all works fine apart from the mini display port. I get the apple logo and boot screen on both of the DVI ports and when plugged into the mini display port with an apple mini display port to DVI adapter. However once booted to the login screen the mini display port goes black. DVI ports are working fine.

    Any ideas? Happy to use the DVI but just interested. Assume it's something to do with something being loaded once the machine has booted?

    It's attached to an old 23 inch apple monitor.

    Thanks for the help.
     
  2. carpsafari Suspended

    carpsafari

    Joined:
    Sep 13, 2015
    Location:
    the Netherlands
    #2
    You would have saved yourself this problem, if you would have read about what types of GPU's to flash and which NOT.
    Congratulations, you chose the wrong model.
     
  3. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #3
    Little bit harsh.... but fair I guess.

    I knew that some wont show boot without VGA adapter and managed to avoid that. As a second card that can sit above the main one without blocking the other PCI slots and let me access recovery/boot screens etc when needed it should do the job.

    Out of interest what is it that kicks in once the login screen comes up that causes the mini display port to cease operation after it has already shown me the illusive boot screen?

    Also, and I assume this is a "how long is a piece of string," type question but as this is the 'wrong' card are there any other issues I should be aware of whilst it's in my machine?

    Thanks again
     
  4. carpsafari Suspended

    carpsafari

    Joined:
    Sep 13, 2015
    Location:
    the Netherlands
    #4
    The miniDisplay in this GPU will work, unflashed!

    PS; bootscreen is THE most overrated quality, imo
     
  5. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #5
    Thanks again. So are you saying that with this card my choices were to use it unflashed and have all the ports working but no boot screens. Or flash it and loose the use of the display port.

    As you say probably should have done a bit more research so thanks for the retroactive help.
     
  6. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
  7. carpsafari Suspended

    carpsafari

    Joined:
    Sep 13, 2015
    Location:
    the Netherlands
    #8
    Its the cheapest mistake you could make!

    Don't tell me you paid more than $50 for it.
     
  8. Jackdown_101, Feb 28, 2017
    Last edited: Feb 28, 2017

    Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #9
    I see now that the thread I looked at said that it wasn't tested on the display port. That's the major mistake... lack of attention to detail
    https://forums.macrumors.com/thread...in-mp-2-1-with-multiple-boot-screens.1938518/

    I have also found after a bit of googling a post on an ebay item from 2011 that confirms what you said but also says,

    With this card you can have up to 3 simultaneous displays on Snow Leopard, each up to 2560 x 1600 resolution. Two displays are supported on Lion. The second detail is that under 10.6.8 and Lion, the MiniDisplayPort isn't active by default. This can be fixed with a small software patch - however, you will still be limited to two displays under Lion.

    Any idea what that patch is? (kext?)
    --- Post Merged, Feb 28, 2017 ---
    Found the Mac Pro Video Cards post on it ...... really should've seen that! Anyone know if there is a sierra equivalent to the Lion patch to get mini displayport working at the expense of a DVI?

    No biggie and thanks for pointing me in the right direction for this sort of thing.
     
  9. Jackdown_101 thread starter macrumors newbie

    Joined:
    Feb 28, 2017
    #10
    To add further to this (even though it's basically a closed thread now) a PRAM reset has bought about the boot screen glitch that a lot of people with Macbook Pros are also talking about.
     

Share This Page