macOS 10.12 Sierra Unsupported Macs Thread

Discussion in 'macOS Sierra (10.12)' started by redheeler, Jun 13, 2016.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. kyeldo, Aug 1, 2017
    Last edited: Aug 1, 2017

    kyeldo macrumors newbie

    kyeldo

    Joined:
    Aug 1, 2017
    Location:
    Rotterdam
    #4901
    I also struggled with this NSURLErrorDomain Error -1100, however a quite simple solution is given on dosdude1 his site:

    Open terminal and run: sudo softwareupdate --clear-catalog

    Run the script that can be downloaded here.

    Updates will be found normally.
     
  2. powermonger macrumors newbie

    Joined:
    Aug 24, 2008
    #4902
    I'm having problems getting this to work on my Mac Pro 3,1 (running 10.12.5, patched dosdude version). Had no problems updating so far through the app store, 10.12.6 however, is not showing up.

    1. Tried the script: failed due to insufficient right (I think because SIP is enabled – can't boot to recovery because of unsupported/non-efi graphic card). So I booted to my secondary harddrive and was able to run the script and modify the LauncherDaemon on my primary harddrive. However, the App Store still shows no updates.
    2. I tried AUSenabler but still nothing shows up inside the app store (tried all channels).
    3. Downloaded the Comboupdate. Installing it without modifying the Distribution will of course quit right away like this:

    (Software not supported by your system)
    [​IMG]

    However...even after modifying the Distribution file by adding my board (Mac-F42C88C8) and removing my model from the unsupported list, I get an error.

    I can start the installation, however, it notifies me with:

    This package is not compatible with your version of macOS and may fail...try anyway?

    [​IMG]

    If I continue, it seems to actually run through but then fails with an error message.

    [​IMG]

    Any ideas? :-(
     
  3. pkouame macrumors regular

    pkouame

    Joined:
    Jul 7, 2016
    #4903
    You probably have SIP enabled. Disable it and it will fly past that error. Worked for me.
    (I have the same mac pro upgrading from 10.12.5 and got the same message. Ignoring the error doesn't work...)

    NOTE: I had to re-boot with an old OS on a stick in Terminal to disable SIP since my recovery partition wasn't working : "csrutil disable" and reboot.
    While you're at it, modify the platform plist on your recovery partition (make sure you mount the right volume!)

    Good luck.
     
  4. powermonger, Aug 2, 2017
    Last edited: Aug 2, 2017

    powermonger macrumors newbie

    Joined:
    Aug 24, 2008
    #4904
    Thank you very much for pointing me into the right direction. After disabling SIP, I was able to install as you mentioned.

    :)

    [​IMG]

    Thank you also for the hint about the platform plist, so I got my recovery partition working again as well.

    By the way: if you have a full backup of your system disk available, you can use this instead of the USB stick. Just boot into it, use diskutil to check where the recovery partition of your (primary) disk resides, mount it, modify the file and reboot with primary disk. Seems obvious, but sometimes you overlook the simple things. ;)

    Edit: also, after disabling SIP, I was also able to run the swupatch.sh script without errors. However, app store never showed any updates (seed or apple production catalog), so I used the modified combo update.

    Edit2: booting into recovery partition does indeed work with my non-supported graphics card as well. Once it's loaded, you will see it, just like OSX you simply won't see anything in boot. I just didn't reach that point because I got the "not allowed icon", where my graphic card is not showing anything. Just wanted to clarify this as it's easy to get into this situation with a mac pro and a non-standard graphics card.
     
  5. Bruce Barton macrumors newbie

    Bruce Barton

    Joined:
    Aug 2, 2017
    #4905
    --- Post Merged, Aug 2, 2017 ---
    I have an early 2008 17" macbook pro 4,1. Just install 10.12.6. Everything seems to work well except the brightness do not work. Anyone else had this problem?
     
  6. parrotgeek1 macrumors regular

    Joined:
    Jun 14, 2016
    Location:
    Midwest
    #4906
    this is happening to me even with real, supported Macmini6,1. MacBookPro11,1 is OK.
     
  7. Bobbytshoes macrumors newbie

    Joined:
    Jul 22, 2017
    Location:
    Australia
    #4907
    Thank you kyeldo that Terminal command removed the error message.
     
  8. pkouame macrumors regular

    pkouame

    Joined:
    Jul 7, 2016
    #4908
    Great! Our old workhorses are standing up pretty well. HS has quite a few performance fixes that may help us squeeze more cycles out of our old Xeons! We're probably a year away from new pros, so 10.13 will be the last OS on my box. You can switch to 10.13 Unsupported to keep up...Good luck.
     
  9. einpa macrumors newbie

    Joined:
    Aug 4, 2017
    #4909
    Yes, macbook early 2009. 10.12.6 installed fine with dosdude patch. Laptop screen brightness low and no response from system when trying to brighten. Also connected to HDMI external monitor. This works good but brightness seems to be locked at ok bright level. Also occasional delay to connect to external resuming from sleep mode.
     
  10. RealAlcibiades, Aug 4, 2017
    Last edited: Aug 5, 2017

    RealAlcibiades macrumors newbie

    Joined:
    Jul 6, 2017
    #4910
    So I'm going to be installing a New Battery in my 2009 MBP 13" pretty soon, I know this will require me to re-disable SID but will I be able to boot into the recovery partition to do so even after replacing the battery? Thanks.
     
  11. MightyMN, Aug 7, 2017
    Last edited: Aug 8, 2017

    MightyMN macrumors newbie

    Joined:
    May 25, 2009
    #4911
    I just finished installing Sierra 10.12.5 to my late 2008 MacBook Pro (5,1) previously I was using the latest El Capitan, but I'm experiencing an App Store hang whenever I click "Store" from the top menu and installing/updating apps always indicates "a minute remaining" and does nothing. I believe the issue is similar to that of @jrwil and @Czo from February, but his issue was never resolved. Everything else seems to be working just fine so far.

    Any thoughts?

    SIP is disabled. When I try to run "softwareupdate -l" in Terminal it never finishes. Something I found in the Console log that could be related(?). Tried rebooting several times. Should I try to reapply the USB patch again?

    Process: softwareupdated [4985]
    Path: /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
    Identifier: softwareupdated
    Version: 977.5
    Code Type: X86-64 (Native)
    Parent Process: launchd [1]
    Responsible: softwareupdated [4985]
    User ID: 200

    Date/Time: 2017-08-07 22:59:33.892 -0700
    OS Version: Mac OS X 10.12.5 (16F73)
    Report Version: 12
    Anonymous UUID: 17E53B66-4DA6-C226-3EBF-8C27A264EAA0


    Time Awake Since Boot: 12000 seconds

    System Integrity Protection: disabled

    Crashed Thread: 0

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Reason: DYLD, [0x9] <unknown>

    Application Specific Information:
    dyld: launch, loading dependent libraries
    DYLD_INSERT_LIBRARIES=/usr/local/lib/SUVMMFaker.dylib

    Dyld Error Message:
    could not load inserted library '/usr/local/lib/SUVMMFaker.dylib' because no suitable image found. Did find:
    /usr/local/lib/SUVMMFaker.dylib: stat() failed with errno=13

    Binary Images:
    0x1057fe000 - 0x1057fffff softwareupdated (977.5) <73030CB2-A818-3A18-A4F5-48A2B543CAEC> /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
    0x1090f1000 - 0x10912edc7 dyld (433.5) <322C06B7-8878-311D-888C-C8FD2CA96FF3> /usr/lib/dyld

    EDIT: I tried to run the post install patcher again with Force Cache Rebuild with no luck. When running the requested commands upon rebooting with Force, this was my console output:

    sudo kextcache -system-prelinked-kernel
    String/URL conversion failure.
    KernelCache ID: C276E1E928C344DE78F2BCF143D06275
    String/URL conversion failure.

    EDIT2: I can see SUVMMFaker.dylib in the proper location and load/unload it, but I'm really not sure what is going wrong. :( Is there any other way to update once high sierra comes out for example?

    Really appreciate the help, fellas.
     
  12. howardc64, Aug 8, 2017
    Last edited: Sep 1, 2017

    howardc64 macrumors newbie

    Joined:
    Mar 14, 2011
    #4912
    A1342 combo card coax connector is slightly different than the ones on Mac Mini 3,1. It is taller and the groove for the latching/click onto securely is lower (Thus doesn't click and easily disconnects). Diameters are the same (both 2mm outer).

    I had no problems with 2 early 2009 Mac Mini. However, 2 late 2009 Mac Mini's antenna coax connector can't really grab securely onto the A1342 connectors. So it appears while early 2009 Mac Mini's antenna coax connector is slightly different than late 09 Minis.

    See pics below. The shorter connector is on the 09 Mac Mini combo board and the taller connector is from A1342 with Apple part number 607-7153-A (607-5952A and 607-6503A are the same).

    I even tried soldering (with a high quality Hakko soldering iron+pointy tip) but the fit is so poor and wasn't successful.

    Here is my post on successful early 09 Mini install for reference macOS 10.12 Sierra Unsupported Macs Thread

    DSCN3329.JPG DSCN3328.JPG
     
  13. brkr1, Aug 9, 2017
    Last edited: Aug 9, 2017

    brkr1 macrumors newbie

    brkr1

    Joined:
    Sep 20, 2016
    Location:
    Salvador-Ba
    #4913
    Can I make a stick from the 10.12.6 installer? If not possible, what's the latest recommended version to go with?
     
  14. lumos macrumors newbie

    lumos

    Joined:
    Mar 10, 2016
    #4914

    Attached Files:

    • bad.jpg
      bad.jpg
      File size:
      3.2 KB
      Views:
      24
  15. gages macrumors member

    Joined:
    Sep 25, 2016
    #4915
    I followed the instruction on Page 194 to modify the package.

    When I run modified.pkg I get a javascript error.
    --- Post Merged, Aug 11, 2017 ---
    OK, found the issue, on the the Board ID line, I had to remove everything except Mac-F42C88C8
     
  16. B1T0Y macrumors newbie

    Joined:
    Aug 12, 2017
    #4916
    Hi,

    Does anybody know if multitouch trackpad modification on macbook white mid 2009 non-unibody still works on el capitan/sierra/high sierra using unsupported mac installation? Do you still see multitouch option on trackpad preference? Want to modify my trackpad, to see if I can use 2 finger tap right click, pinch to zoom etc. Wondering if I did this modification it will work to have multitouch? Thanks.
     
  17. KernkraftX360 macrumors member

    KernkraftX360

    Joined:
    Sep 23, 2016
    #4917
    How did you do it, mate? Please share, I'm using a Mac Pro 2008 too, and AUSenabler says there are no updates at the moment. :(
    --- Post Merged, Aug 14, 2017 ---
    How did you do it, mate? Please share, I'm using a Mac Pro 2008 too, and AUSenabler says there are no updates at the moment. :(
     
  18. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #4918
    After following the instructions from post #4901, the update worked for me.
     
  19. Smacky, Aug 15, 2017
    Last edited: Aug 15, 2017

    Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #4919
    Hi guys, so I have decided to reformat and go back to El Capitan before selling my MBP (mid 2009).

    I re-enabled SIP from the command line, wiped the drive and installed a fresh copy of El Capitan from a USB stick. However I find that the trackpad doesn't register clicks anymore. I can move the cursor around but can't click or double click anything.

    Has anyone else run into this issue going back to El Capitan, or know of what the issue might be? I can't really sell a MBP without a properly functioning trackpad!

    Is there a proper way to 'remove' a patched installation so everything goes back to standard?

    Cheers
     
  20. KernkraftX360 macrumors member

    KernkraftX360

    Joined:
    Sep 23, 2016
    #4920
    Cheers, it works splendidly and effortlessly on my 3,1 Mac Pro :)
     
  21. DarrenNI macrumors newbie

    Joined:
    Sep 21, 2012
    #4921
    Hi folks,

    I patched my 2009 MBP months ago and everything was working fine until recently, where there's only ever one app showing with an update in the App Store, and when I click Update, the App Store just hangs.

    I've tried the various fixes in this thread, running the various scripts, deleting caches, etc. but no luck.

    Any ideas where to go next?

    thanks!
     
  22. msjjap macrumors newbie

    Joined:
    Aug 16, 2017
    #4922
    I've also run into the brightness issue on three different iMac 9,1 (20" from Early 2009) models in recent weeks. The computer won't respond to brightness changes either from the keyboard or from the Display system preference.
     
  23. Jack Neill macrumors member

    Jack Neill

    Joined:
    Sep 13, 2015
    Location:
    San Antonio Texas
    #4923
    Brightness Slider is decent app for overcoming this, I used it on my 5,2
     
  24. parrotgeek1 macrumors regular

    Joined:
    Jun 14, 2016
    Location:
    Midwest
    #4924
    this is happening to my 2012 mac mini, it is some apple bug
     
  25. NetFlyer macrumors newbie

    Joined:
    Jul 8, 2016
    #4925
    Hello to all,
    i wanted to install sierra on my imac 9.1. I followed the dosdude's instructions to create the installer from usb. The procedure is fine, but when I boot from the usb drive, the prohibition symbol appears and can not proceed with the installation. Where did I go wrong?
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page