Messages Mystery... Please Help this Damsel in Distress

Discussion in 'macOS Sierra (10.12)' started by ItsAShaunParty, Nov 17, 2016.

  1. ItsAShaunParty macrumors newbie

    Joined:
    Jun 20, 2013
    #1
    Hey all!

    My problem? Can't get into Messages on my Macbook (explained below). Authentication. This is killing me. It's driven me nuts since the beginning of October. I spend a solid 5-10 hours a week trying to fix it. Called Apple (they sent it to engineering and took a log of my computer when I start up messages). I never heard back and emailed the woman a few times. That was four weeks ago. Also went to the store, Dumbfounded. I used to work at The Apple store and I feel like we cared a lot more than these guys and gals. A guy like me would've never left until it worked.
    So, please, my family, lend me your support -- Fix my mac!

    Other people have this issue. A handful. They try all the normal tricks -
    GO!

    OS: Sierra 10.12.1
    System: Macbook11,1 MacBook Pro (Retina, 15-inch, Late 2013) with a 2.3 GHz Intel Core i7 and 16 GB Ram.

    Issue: Messages produces "An error occurred during authentication." Facetime as well. This has been for over a mont. I am an Apple Store alumnus and when I went there with the issue, the Genius bar was dumbfounded. I called support. Support passed it to engineering. four weeks ago. This is a screenshot of the issue: http://i.imgur.com/wiMkMvq.png

    It's the System: It must be an issue with this system. I know this because I also have a Macbook late 2008 on the same network. On that computer I can log-in no problem. Another Apple ID I have also gets the same error on this system.

    Theory: My knowledge is limited in this area but I have a theory. I believe the ports that Apple uses to contact its authentication servers are being blocked locally. I simply do not know how to unblock them.

    More specifically, it seems the ports 53, 80, 443, 4080, 5223 need to be open for FaceTime and Messages. Both of these apps alert the "/etc/pf.conf" file to open the necessary ports while they are running. I believe that Messages and FaceTime are not able to do this. In other words, both apps rely on the same mechanism of opening the correct ports on the Macbook. This mechanism is failing, it seems.

    After running some scans I believe these ports are closed. And they probably ought to be until they are opened by an app to use them.

    The only things I can think of -- and I'm not sure if my memory is correct at all, is that I may have ended a process weeks ago that does this. Also, I may have used a command in terminal in an effort to try to turn off IPv6. I can't remember. This may also not be related.

    References: I relied heavily on these articles for information:
    This article written by Apple seems to suggest this: [URL='https://support.apple.com/en-us/HT202078[/url]']https://support.apple.com/en-us/HT202078[/URL]
    This article by Apple may also be of interest: [URL='https://support.apple.com/en-us/HT202944[/url]']https://support.apple.com/en-us/HT202944[/URL]

    So Far: I've followed all the basic and not so basic. I've cleared (I think) all the related plists. Maybe I'm missing one. I've cleared the keychain of messages (did I miss something?). NRAM/PRAM, safety mode (didn't work), and some other random stuff. Nothing.

    Please map out any tech support step by step so I can be sure i don't miss anything.

    Thank you!!!!
     
  2. ohhitherefolks macrumors newbie

    ohhitherefolks

    Joined:
    Nov 17, 2016
  3. rnbwd macrumors regular

    rnbwd

    Joined:
    Jul 6, 2015
    Location:
    Seattle
    #3
    what's the contents of /etc/pf.conf? there's a third party firewall i used called murus which leverages pf (packet filter) firewall that normally lies dormant from the linux OS darwin is based on... anyways the default behavior is to link into a default apple 'pf table'. there's a 'pfctl' command line built in that can be used to see what's up, or murus to visually see what ports are open and closed. i haven't found any documention from apple regarding this behavior but there's a guide linked on murus website
     
  4. n3acal macrumors newbie

    Joined:
    Sep 10, 2015
    Location:
    Switzerland
    #4
    I have exactly the same problem. Any new ideas or fixes?
     
  5. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
  6. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #6
    Have you checked your router? 9/10 this issue is nothing to do with the mac and all to do with the router.

    Easiest way to rule the mac out is to create a second user account and try logging in to iMessage from it. If it logs in the there's an issue with a setting or somesuch on your main account. However if the same issue persists then it's an external issue.
     
  7. DaveOP macrumors 65816

    Joined:
    May 29, 2011
    Location:
    Portland, OR
    #7
    Have you tried this activation outside of the home, or at least on a phone hotspot?
     
  8. post/ergo, Dec 14, 2016
    Last edited: Dec 14, 2016

    post/ergo macrumors member

    Joined:
    Mar 26, 2009
    Location:
    Great Britain
    #8
    Of the top of my head in no particular order (sorry long day) The error in the screen shot shouts network to me (I could well be wrong)

    I know you said the other macbook on the network does not have these problems so let's look at localhost netconfiguration.

    DNS: This may be handled by the router or perhaps locally - check System Preferences > Network > the active network > Advanced > DNS. Is this the network's default gateway (likely 192.168.0.1 or similar) or an external DNS (google's DNS, openDNS, etc.? Is this the same as the other macbook?

    While you are there check the Proxies tab in the Advanced window as well.

    Firewall: Try turning the system firewall off and see if it works after that. Alternatively, check the router, these can have firewalls too and on some this can be set to allow/deny different ports to specific hosts (computers) connected to it.

    The idea from the post above about trying a 2nd user account and attempting to set up with that is not a bad idea.

    Network Settings: Now this could do more harm than good but this will reset the network configurations to factory defaults.

    1.Remove the /Library/Preferences/SystemConfiguration folder,
    (in terminal: rm -rf /Library/Preferences/SystemConfiguration/ Please be very careful with the rm -rf command and stay away from the enter key until you are ready.)

    2.Then clear the PRAM by cold booting while holding down command-option-p-r until you hear the startup chime a third time.


    Saying all of this if you are spending the time you way you are on this I personally would bite the bullet and do a clean install with 10.12.2. in fact just give updating 10.12.2 a go - what's to loose.

    ^ all a bit of a brain dump, please ask if anything is unclear.
     
  9. ItsAShaunParty thread starter macrumors newbie

    Joined:
    Jun 20, 2013
    #9
    Thank you so much for this @post/ergo ... trouble is, I already tried all of that! Same error!

    Been getting help from Apple Senior Support Staff... for a few months now. Upgraded OS, etc. Trying to avoid a clean install but it's not looking good.

    Anyone have any other ideas?

    I just sent them a new sysdiagnose file so hopefully that'll show something...

    I think it's a setting that is off in the OS. Maybe from installing the PIA VPN Client back in september. Something with the ipv6?

    Thoughts?
     
  10. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #10
    Use your Mac for this:
    Go to your iCloud.com and log in there. Look on the Settings page and see if your Mac is there - now click the Mac and choose the Remove text which is a button too.

    After doing that turn off your computer. Power it down. After a while you should be able to power it on again - now zap nvram and try activating.

    Some of the text above is taken from a 9to5 user called Jeffrey Siegel who comments on the story here: https://9to5mac.com/2016/03/23/cant-log-in-to-imessage-facetime-os-x-10-11-4/
     

Share This Page