Some Users With Older Copies of iLife and iWork Having Difficulties Upgrading to New Versions [Updated]

Discussion in 'Mac Blog Discussion' started by MacRumors, Oct 22, 2013.

  1. rdekruyf macrumors newbie

    Joined:
    Oct 23, 2013
    Location:
    The Netherlands
    #126
    None of all the tricks above worked for me :(
    Maybe Apple is allowed the updates by country?
     
  2. mac1984user macrumors 6502a

    mac1984user

    Joined:
    Dec 10, 2009
    Location:
    United Kingdom
    #127
    I just wanted to confirm that making a new user and then upgrading the disc-based iWork apps worked perfectly. Of course, this was after I spent £13.99 on a new version of Pages, because I wanted to continue with my work between the iPad (which had already updated) and the Mac. Next time, I'll be more patient (though, it DID seem like something Apple would do - punish all those who would dare use something as passé as a DVD).
     
  3. NightFox macrumors 68020

    NightFox

    Joined:
    May 10, 2005
    Location:
    Shropshire, UK
    #128
    All my iWorks and iLife apps (DVD installed, not MAS) seem to have updated for free now, still don't really understand the criteria though.

    However, I'm still confused over one thing - if the new iLife apps are a free upgrade to iLife '09 and iLife '11 owners (as it now seems, even for DVD installs), why does Apple even have a price for the new iLife apps? Surely every computer on which Mavericks can be installed will have come with a copy of one of these iLifes when new, so how is anyone going to be in a position where they wouldn't be entitled to a free upgrade? In other words, how would anyone not have an earlier version of iLife?
     
  4. KiwiAdventure Suspended

    Joined:
    Dec 7, 2010
    Location:
    New Zealand
    #129
    All worked for me and after updating I deleted the old iLife 09 and iMovie.:)
     
  5. Attonine macrumors 6502a

    Joined:
    Feb 15, 2006
    Location:
    Kent. UK
    #130
    Just checking. This only applies to iWork 09 and on? I have iWork 08 and just assumed I would be paying to update, nothing appears in MAS regarding iWork for me.
     
  6. macchiato2009 macrumors 65816

    Joined:
    Aug 14, 2009
    #131
    I have bought iWork & iLife through the App Store, now that the new versions are available, the App Store doesn"t want to update them and offer me to buy the new versions :mad: :(
     
  7. tfigs macrumors member

    Joined:
    Dec 20, 2012
    #132
    It worked

    I had iLife '11 and iWork '09 both installed by disk. I woke up this morning and updates were there in the Mac App Store. After updating, all apps showed up under "Purchases":)
     
  8. macchiato2009 macrumors 65816

    Joined:
    Aug 14, 2009
    #133
    that's normal

    but can you update to the latest versions ?
     
  9. RayK macrumors 6502

    Joined:
    Oct 13, 2005
    #134
    I may be very late in saying this but I thought the same thing since I only owned the DVD copies. They attached to my Apple ID and updated. There appears that they had tons to change yesterday so I would be patient.

    ----------

    I can.
     
  10. duky macrumors 6502

    Joined:
    Jun 25, 2007
    Location:
    North Carolina
    #135
    Yup everything's working normally for me today but yesterday was all messed up. Looks like they fixed this
     
  11. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #136
    Working for me also. All apps originally installed from DVD and after updating they appear in the Purchases tab on the App Store.

    [​IMG]
     
  12. SvP macrumors 6502

    SvP

    Joined:
    Mar 31, 2009
    #137
    You're posting this a lot. I suspect you feel less special if more users got the updates for free. You'd rather stay in the "lucky" group, the happy few.

    It's the difference between jealousy and envy. Try not to envy, and be jealous instead. Your life will be better for it :)
     
  13. oacory macrumors regular

    Joined:
    Jun 11, 2008
    Location:
    New Jersey
    #138
    This is what I did and it worked for iLife. Don't have iWorks to verify. I have only bought iLife apps on DVD so never made an iLife purchase for the Mac App Store to pull from.


     
  14. auriconis macrumors regular

    Joined:
    Mar 26, 2012
    Location:
    NJ
    #139
    I was having the same issue yesterday with the apps not showing up. I had bought them on DVD as well. This morning, they finally appeared as an update. I guess for those of you who haven't seen them yet, just be patient, they will eventually appear.
     
  15. dugbug macrumors 65816

    dugbug

    Joined:
    Aug 23, 2008
    Location:
    Somewhere in Florida
    #140
    In case this happened to others: After selecting update in the MAS, they seemed to disappear. The MAS update page showed no record of them being updated, and trying to launch them resulted in the "this app is being updated" message.

    I went to launchpad and saw several icon-less entries that had a load progress bar and 'paused' over it. I clicked to resume and they downloaded fine.

    Not sure why this happened or why the MAS software update page lost its mind but it all works now.

    And sparkly effects for new apps? I love you but come on apple. At least I don't use launchpad.
     
  16. G-Force macrumors 6502a

    Joined:
    Nov 25, 2006
    #141
    Still not working for my iLife '11 retail version. I don't know what's wrong here...
     
  17. Kebabselector macrumors 68030

    Kebabselector

    Joined:
    May 25, 2007
    Location:
    Birmingham, UK
    #142
    Any Apple love for us still on iWork 08?

    (I know I should've upgraded it a while ago)
     
  18. Graeme43 macrumors 6502a

    Graeme43

    Joined:
    Sep 11, 2006
    Location:
    Great Britain (Glasgow)
    #143
    I got the iWork and iLife apps simply by installing 10.9 into a parallels machine then signing in with my Apple ID :D

    Was having issues with it telling me the apps were downloaded with another ID previously
     
  19. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #144
    Daft question but have you updated to Mavericks yet?
     
  20. G-Force macrumors 6502a

    Joined:
    Nov 25, 2006
    #145
    Yes I have, first I upgraded from Mountain Lion to Mavericks, no updates. This morning I've installed Mavericks clean and installed my iLife '11 dvd and still no updates.
     
  21. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #146
    Sorry for "yelling" at you. I didn't follow forum ediquite. I just tried to make it bold for people to see and use as it's a easy, quick, proven, solution I'd found on another forum (linked) that helped me with this situation.
     
  22. robjulo macrumors 65816

    Joined:
    Jul 16, 2010
    #147
    For me (iMac 2012), both iPhoto and iMovie showed "install" with no price. iPhoto updated with no problems. Tried the same with iMovie and it claimed it wasn't purchased from the App store and I would have to buy it. said OK and it downloaded, apparently without really having to buy it.
     
  23. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #148
    or better check your visa charges ion a couple days... :eek:
     
  24. Swiss-G macrumors 6502a

    Swiss-G

    Joined:
    Jun 3, 2010
    Location:
    United Kingdom
    #149
    Ok, have you tried logging in with a new user account?

    I used the guest account and then logged in to the MAS and the updates appeared.

    You could also try registering the iLife '11 apps with the AppleID you want to upgrade with.
     
  25. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #150
    So them on perfectly legit DVD copies just have to buy new App Store copies of the same software right? So my G4 can run iWork 09 perfectly fine but my newer intel MacBook on Mavericks can't unless I buy it again?

    It's weak. And it needs to be fixed. I'm glad Apple are on the case.
     

Share This Page