Upgrading 2013/2014 Macbook Pro SSD to M.2 NVMe

Discussion in 'MacBook Pro' started by maxthackray, Mar 1, 2017.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. denj macrumors newbie

    Joined:
    Dec 7, 2018
    #2676
    Ah I'm sorry, I didn't explain myself properly. I used a Mojave installation usb to install Mojave onto an original apple ssd.

    My Boot ROM Version: 149.0.0.0.0 and
    my SMC Version (system): 2.19f12

    That said, do I still need to disable hibernate or flash the chip as per a previous poster's instructions to avoid sleep issues?
     
  2. avdo macrumors newbie

    avdo

    Joined:
    Nov 25, 2018
    Location:
    UK
    #2677
    Shame.

    Just build a standalone installer of the 10.14.2 EFI firmware update. Again, no dice as it would appear that the SSD is checked as part of the verification process.

    Looks like I'll have to keep the original drive
     
  3. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2678
    Was the original Apple SSD inside the Macbook at the time of installation?

    Yes, you will need to disable hibernation or flash a modded bootrom to avoid panics associated with sleep.
    --- Post Merged, Dec 9, 2018 ---
    I have an Intel 600p SSD inside an early 2015 13" Air. When I updated to 10.14.1 from 10.14, the update did update the bootrom. This is the first time that my Air accepted a bootrom update with an nvme drive inside.

    You could sell the original drive and buy a smaller Apple SSD to keep for bootrom updates?
     
  4. denj, Dec 9, 2018
    Last edited: Dec 9, 2018

    denj macrumors newbie

    Joined:
    Dec 7, 2018
    #2679
    Yes, it was.

    From this link https://apple.stackexchange.com/que...e-ssd-drives-via-the-use-of-a-sintech-adapter

    I've done a little research into transplanting NVMe Driver from one firmware to another and I did the following:
    In Terminal: /usr/libexec/firmwarecheckers/eficheck --integrity check and found that my EFI version was actually: MBP112.88Z.0147.B00.1809171519

    Downloaded the latest combo update as a test: https://support.apple.com/kb/DL1987?locale=en_US

    From pkg, Extract EFI/Payloads directory, find this file, MBP112.scap and open it using UEFI Tool mentioned in the guide earlier.

    Seached and found the same EFI version mentioned above and checked for the same GUID NVMe driver "511116915..."

    Then follow Y. H. Wong's idea of transplanting NVMe Driver from MBP114.fd to MBP112.scap via UEFI Tool:

    /usr/libexec/efiupdater -p /path/to/EFIPayloads --force-update

    I'm pretty sure this will work but I don't want to brick my system since I don't have a CH341A or another machine to use.

    Given these steps, do any of you foresee a problem?
     
  5. ponta pon pon, Dec 9, 2018
    Last edited: Dec 11, 2018

    ponta pon pon macrumors newbie

    Joined:
    Oct 22, 2018
    #2680
    I am currently considering buying 1 TB of the ADATA XPG SX8200 series.
    What is the difference between using SX8200 and SX8200 Pro on “MacBook Pro Retina 15' Late2013” ?
     
  6. tshelby73 macrumors member

    Joined:
    Jul 24, 2018
    Location:
    Gillette, WY
    #2681
    I personally see it failing due to the signing but if does work that would be awesome. Keep us updated on the progress.
     
  7. Slezi macrumors newbie

    Joined:
    Dec 10, 2018
    #2682
    Hello,
    anybody tried input HP EX900 to MBA 6,2 (mid 2013)? I tried updating recovery (cmd-opt-r), boot on ubuntu linux and search for that disk, updating boot rom (my conf in screenshot) and no effect, disk is not recognized.
     

    Attached Files:

  8. gaijin141 macrumors newbie

    Joined:
    Nov 12, 2018
    #2683
    I was unable to get the efiupdater command with the --force-update flag on to upgrade my Macbook Pro 2013 to the latest stock firmware from 10.14.1, so not sure if the above will work.
     
  9. Rikkami macrumors newbie

    Joined:
    Dec 10, 2018
    #2684
    Hey guys, can anyone help me?
    Bought the Sintech Adapter and tried to mount a Samsung 970 Evo. I'll try to give many Information as possible.

    I got a MacBook early 2015 with 128 GB SSD delivered with El Capitan. I'm using it for 2 years now. OS Mojave made my battery very weak so I reinstalled High Sierra. Then I opened my Mac, disconnected the battery and used the Sintech Adapter on my Samsung Evo 970 500 GB. It took me a while that the MacBook recognized the HDD because of the partition. Now it doesn't let me instsll High Sierra from a bootable USB because it says, that my SSD is a PCI and needs a GUID partition. If I press erase I press OS Journaled partition and get a succesfull message. But I still can't install OS X again.

    Any suggestions?
     

    Attached Files:

  10. Slezi macrumors newbie

    Joined:
    Dec 10, 2018
    #2685
    Hello, anybody has problem with unpack FirmwareUpdate.pkg?

    when i type
    pkgutil --expand FirmwareUpdate.pkg FirmwareUpdate

    Could not open package for expansion: FirmwareUpdate.pkg

    tried with sudo too, file exist in folder (auto type with tab using so name is good)
     
  11. mbosse macrumors 6502

    Joined:
    Apr 29, 2015
    Location:
    Vienna, Austria
    #2686
    Can you go to ‚Darstellung‘ and let it display all devices? Then select the top device level and show us the screenshot again?

    Magnus
     
  12. weckart macrumors 601

    Joined:
    Nov 7, 2004
    #2687
    From the little I have seen, the Pro version seems to run at the same temps as the non-Pro version, so its faster controller seems to be reasonably frugal. Your MBP only has PCIe 2.0, so you won't see any faster sequential read/write speeds over using the non-Pro version. Costs of both sticks seem to be identical. Hopefully, we'll see some tests on Mac hardware soon.
     
  13. erudyne macrumors newbie

    erudyne

    Joined:
    Oct 17, 2018
    #2688
    I'm about the farthest from an expert on anything here, but is there a software method of dumping your current firmware to file and putting it on a usb drive so that you have something to recover off of in case it goes wrong? You'd still need to get a CH341A and borrow a computer, but at least then you'd have some recourse.

    I don't know if that's possible, but it seems like it would be a good idea. I'm super interested in the outcome of your experiment here, so if you do try it, be sure to let us know!
     
  14. erudyne, Dec 12, 2018
    Last edited: Dec 12, 2018

    erudyne macrumors newbie

    erudyne

    Joined:
    Oct 17, 2018
    #2689
    Wait, how were you able to modify the scap file with UEFI Tool? The latest version has the replace option disabled and the old version won't open scap files.

    I can dump the EFI rom to a .bin, but I don't know if you can flash that through efiupdater.

    EDIT: Okay, I renamed the scap file to fd and it let me open it fine. That feels a little wrong, but I did the replace, verified it, everything looked good. Ran the efiupdate as described and rebooted, but it didn't appear to actually do anything. There were no errors I noticed through the efiupdate process and I ran it as root.

    I'm on the previous mojave bootrom (.0146) so I thought I would use this as an opportunity to upgrade. Checked system report when I got back to osx and it was still showing 111.0146.000 instead of the newest Mojave bootrom version (.0150 I think it was?). I also extracted the rom and checked the checksum, which was still the old version.

    Maybe I missed a step, but I don't feel like it. Maybe I need to update to regular .0150 first, but I kind of doubt that as well.
     
  15. gaijin141 macrumors newbie

    Joined:
    Nov 12, 2018
    #2690
    I tried using the efiupdater command just to get version 149.0.0.0 installed from the 10.14.1 combo updater. Like you, I ran as root, got what looked like success but then rebooted and nothing happened. No update.
     
  16. erudyne macrumors newbie

    erudyne

    Joined:
    Oct 17, 2018
    #2691
    Found a whitepaper that might have something to do with that:
    https://www.blackhat.com/docs/eu-17...e-State-Of-Apples-EFI-Security-Support-wp.pdf

    I don't know for sure, but maybe it's detecting the fact that the rom has been modified and is blowing off the flash? It goes on to talk about how to do the work manually, which I haven't tried yet. It's worth noting that this paper is basically about rootkit development methodology, so I don't know what the implications of reading/using it are.

    I tried taking the modified bootrom and repackaging it into the combo updater, and it tried to run (warned it would damage my system, so it detected that I messed with it) but it ended up exiting with an unspecific error about how it couldn't complete. A reboot after (hey, I could get lucky) showed that nothing significant happened.

    Something else I tried was installing the factory hard drive and doing the update that way. My modified efi did nothing, but the stock combo update did get me to 149. So it's not the hard drive blocking it.

    My next step is going to be making up a manual update process from that whitepaper and attempting that.

    If anyone has 50 rep on Stack Overflow (I only have 8 :( ) and wanted to do someone a solid favor, it'd be awesome if you ask "Y.H Wong" if he can give a more complete explanation of how he did it.
     
  17. wawon, Dec 12, 2018
    Last edited: Dec 17, 2018

    wawon macrumors member

    wawon

    Joined:
    Oct 2, 2017
    Location:
    Japan
    #2692
    I found a new problem.
    I used sintech ST-NGFF2013-B so far, but I purchased sintech ST-NGFF2013-C this time.
    I found a problem Reference code: PPN001 displayed in Apple Diagnostics.

    Reference code: PPN001 (not found in reference codes list)
    There may be an issue with the power management system.

    SMC reset and NVRAM clear have no effect.

    ---------
    ..........................................EFI ........................ ST-NGFF2013-B.................................... ST-NGFF2013-C
    ................................................MZ-HPV256...SUNEAST NVME 512GB...MZ-HPV256...SUNEAST NVME 512GB
    MacBook Pro 13 2014 149.0.0.0.0 ...........OK.....................OK...................... NG...................NG
    MacBook Pro 13 2015 180.0.0.0.0 ...........OK.....................OK....................... NG..................NG

    MZ-HPV256: samsung PCIe AHCI
    SUNEAST NVME 512GB: suneast PCIe NVMe

    sintech ST-NGFF2013-B: isolated pins by myself, shows PCIe 2.0 x4 5MB/s
    sintech ST-NGFF2013-C: no treatment, shows PCIe 2.0 x4 5MB/s

    OK: always showed ADP000: No issues found.
    NG: sometimes showed PPN001: There may be an issue with the power management system.
    ---------

    I estimate that the power manager detected unexpected power consumption, but ST-NGFF2013-B and ST-NGFF2013-C should be the same circuit and it is suspected that a leak occurred somewhere.

    Apple Diagnostics
    https://support.apple.com/en-us/HT202731

    Apple Diagnostics- Reference codes
    https://support.apple.com/en-us/HT203747

    MacBook Pro late 2013 13” PPN001 PFM006 fan at full speed and slow
    https://www.ifixit.com/Answers/View/491642/MacBook+Pro+late+2013+13”+PPN001+PFM006+fan+at+full+speed+and+slow

    Apple diagnostic PPN001. Fan running high, computer slow
    https://discussions.apple.com/thread/8403877


    [Additional notes 2018/12/13]
    I suspected that pins are not insulated well, so I did same insulation treatment for ST-NGFF2013-C as ST-NGFF2013-B. The problem was resolved. Although ST-NGFF2013-C is affixed with insulation tape from the time of purchase, it seems to be insufficient even PCIe lane is x4.

    [Additional notes 2018/12/17]
    Unfortunately it was a mistake that I thought that the error code was resolved. It was found that even if the number of tests was increased, ST-NGFF2013-B or ST-NGFF2013-C occurred even if insulation treatment was applied. However, no error occurs in Apple's genuine SSD.
    It is not clear what the cause is, but since all of the MacBook Pro 13 used for this test has 16 GB of RAM (usually 4 GB, 8 GB), It may be that there is little margin with the power consumption to judge (it is a selfish guess to the last).
     
  18. turbineseaplane macrumors 601

    turbineseaplane

    Joined:
    Mar 19, 2008
    #2693
    Where'd you get that adapter from?
    Is that the short or full length one?

    (Having trouble searching the model number - thx)

    --- Post Merged, Dec 13, 2018 ---
    I just grabbed a 2TB Samsung 970 EVO to try out in my 2015 15" MacBook Pro

    Should I be getting the short or long Sintech adapter?

    Long: http://a.co/d/8rmlmGv
    Short: http://a.co/d/ap6JkQo

    Do I have the right product links there?


    Thanks for any expertise from anyone with Samsung EVO 970's
     
  19. turbineseaplane macrumors 601

    turbineseaplane

    Joined:
    Mar 19, 2008
    #2694
    So - I bought this adapter after seeing confirmed reports of the EVO drive working with it in the 2015 15"

    Adapter: http://a.co/d/ap6JkQo


    My plan so far, unless anyone tells me a better way, is to use:

    macOS Mojave Patcher from:
    http://dosdude1.com/mojave/

    ...to make a bootable USB installer and then boot to that and install a fresh copy of Mojave on the installed EVO drive and then restore from a time machine backup.

    Good idea?
    Anything I'm missing?

    Will I have the correct bootrom by installing a fresh copy of Mojave this way or will I still get stuck with an older, non NVME ready, bootrom if I do it this way?
     
  20. notgonna macrumors newbie

    Joined:
    Sep 24, 2018
    #2695

    I bought that short one. Worked well.
     
  21. turbineseaplane macrumors 601

    turbineseaplane

    Joined:
    Mar 19, 2008
    #2696
    Cool - thx
     
  22. avdo macrumors newbie

    avdo

    Joined:
    Nov 25, 2018
    Location:
    UK
    #2697
    Provided your at 10.13.6 with latest security patches you'll be at the same Bootrom version that Mojave is at on a 11,4 MBP

    I wouldn't use that method for the USB install. Either create one yourself via Terminal or download Disk Creator and use that if your not comfortable with Terminal.
     
  23. Berlinsky macrumors newbie

    Berlinsky

    Joined:
    Nov 23, 2018
    Location:
    Berlin
    #2698
    The adapter Looks good. Mine is green but they should be The same. There is no need for The Mojave Patcher. I even think it would be counterproductive. I updaded to 10.14.1 with the Apple 256SSD. Then changed the SSD and Booted from an usb device. From there i installed Mojave. Everything went smooth. Never Had a Kernel panic. Also check here for further infos on specs and correct EFI versions and other helpful infos:
    https://beetstech.com/blog/apple-proprietary-ssd-ultimate-guide-to-specs-and-upgrades

    https://eclecticlight.co/2018/12/11/lockrattler-4-18-should-now-highlight-new-updates/

    Also I like the painting perspective...
     
  24. lexis_spb macrumors newbie

    Joined:
    Nov 18, 2018
    #2699
    Small update. Macbook pro 13 inch late 2013. High Sierra won't install on original Apple SSD because of failing SMART. I try several times to install High Sierra and Mojave on Apple SSD. Finally I plugged additional USB3 drive and installed Mojave and run it several times (it's wokring slower but wokring).
    In addition I clone USB3 Mojave to internal Apple SSD using Disck Utility. So finally I had Mackbook running on original Apple SSD.

    Finally I've discovered that my bootroom was updated to 149.0.0.0! I cannot tell when this happened. Sorry...
     
  25. turbineseaplane, Dec 14, 2018
    Last edited: Dec 14, 2018

    turbineseaplane macrumors 601

    turbineseaplane

    Joined:
    Mar 19, 2008
    #2700
    Ok - So there's a way to create a normal/legit Mojave USB installer?
    I had no idea - thank you...

    Making one in Terminal now....made


    --- Post Merged, Dec 14, 2018 ---
    How do you guys normally do your data transfer here onto these new NVME drives?

    Would you suggest just restoring from a Time Machine backup?
    A full/complete clone with CarbonCopyCloner?

    Normally I'd mount up the former internal drive and restore right from that to the new internal, but that Apple SSD with it's unique connector gets in the way of that in this case, so I'm thinking of just doing Time Machine restore from Backup when installing Mojave on the 970 EVO.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page