Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Weird WiFi Issue/Bug on both personal and work iPhones!

harrisonjr98

macrumors member
Original poster
Dec 15, 2019
83
65
Having a weird issue!

Both my work iPhone 8 Plus and personal iPhone X (both always updated to the latest software) have had a problematic behavior for years now, but either I’m noticing it more being at home often or it’s getting worse. When they’re asleep, locked, and connected to WiFi, they will occasionally get into “spells” (I don’t know how else to describe it) where, upon waking up, you’ll see the WiFi connection briefly disappear and go to LTE and then re-establish itself.

It happens on both of my phones, both my home WiFi and work WiFi, and seemingly at random. It appears to be temporarily solved by restarting the phone but can come back anywhere from a few minutes to a few days later and then happen sporadically from there.

Is this some kind of intentional thing? Is it a known iOS bug? I definitely recall it happening on occasion pre-iOS 13, but only on my personal phone iirc. When I saw it on my work phone too it really began to puzzle me! Sometimes it’ll happen at the same time on both, but usually not.

I don’t have unlimited data, so it irks me to think that potentially the phone is just chilling on LTE succin’ up my data for no reason when it’s in range of WiFi. Of course, I don’t know if that’s actually the case- it could just be a visual bug for all I know.

ANY guidance/help/“I have this too” is much appreciated. Thanks in advance!
 

harrisonjr98

macrumors member
Original poster
Dec 15, 2019
83
65
Looks like this is the same issue you posted in the iOS 13 forum, and you're getting a consistent message from all.

It is, I x-posted because I wasn't sure which it would be more applicable to. Thanks all for the insight.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.