Resolved Force 2011 MacBook Pro 8,2 with failed AMD GPU to ALWAYS use Intel integrated GPU (EFI variable fix)

Discussion in 'MacBook Pro' started by AppleMacFinder, Mar 18, 2017.

  1. miscend macrumors regular

    Joined:
    Nov 5, 2009
    #2601
    I've followed MikeyN's Guide on page 35 post #875 . But for some reason now Firefox no longer works, it opens but no longer displays web pages. I'm running High Sierra 10.13.6. I'm also running the Steve Schow fork of GfxCardStatus.
     
  2. KolfMAKER macrumors newbie

    KolfMAKER

    Joined:
    Jul 13, 2019
    Location:
    The Netherlands
    #2602
    This is exactly the issue I have, great there is a solution!

    I have booted with CMD + S and followed the 9 steps as described just below. Unfortunately, I get stuck at step 5. When that command tries to remove the AMD drivers cache, I get 14 subdirectories listed with the error message "Operation not permitted". So I cannot continue with steps 6 till 9.

    What Can I do about this?

    ================================================

     
  3. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #2603
    I just wanted to say, thank you so much.

    My trusty 8,2 lasted years, but died after it became Vintage last year, so there was no way to get a replacement board. What made my situation worse was that I'd enabled FileVault and added a Firmware Password, making this task seemingly impossible..

    However while trying to boot it up again randomly, the screen unexpectedly sprung to life 15 minutes into booting; turns out RecoveryOS uses the iGPU on this model.. so there was a chance! The Mac was booting to RecoveryOS because after a minute at the FV2 screen, macOS assumes you're having issues logging in, and should set nvram to boot to RecoveryOS (specifically with the recovery options for FV2).

    As I could get to RecoveryOS, I could plug in a macOS installer, use Startup Disk to reboot to it, and disable the Firmware password. I re-installed Sierra (for testing; the only OS I had to hand as a DMG), ran the nvram commands you listed, and relocated the AMD Kexts, and rebooted.. and the thing works!

    Sadly this isn't really useful for gaming any more, but I mostly used it for Ableton Live performances, so it's great to have it back :)

    Restoring 10.12.6 and performing all the available patches worked as normal; you'd never know there'd been an issue!

    Next thing is to test with High Sierra, then perhaps test Mojave..

    But thanks again :)
     
  4. H-P., Jul 21, 2019
    Last edited: Jul 21, 2019

    H-P. macrumors newbie

    Joined:
    Aug 24, 2015
    #2604
    Hi there,

    My macbook pro 2011 had two motherboard replacements in warranty, but died for the third time a couple of months ago. This thread is a lifesaver! :)

    I tried two fixes yesterday:

    - the simplest way as described in the first post: it worked, but I had to do this procedure with every boot, which is annoying.
    - the nvram solution with tool from dosdude1's website (http://dosdude1.com/gpudisable/): it worked and it boots everytime without problem, but sleep/wake and brightness controls don't work (did work with the first fix).

    I'm looking into the hardware mod of soldering and applying the demux firmware for a more permanent solution, but I'm using the quick fix(es) for the time being. Is there a solution to get sleep/wake and brightness controls to work? Is there a combination of the two fixes possible?

    Thanks in advance!
     
  5. IKSector macrumors newbie

    IKSector

    Joined:
    Jul 23, 2019
    Location:
    Lagos Nigeria
    #2605
    Please, has anyone managed to test out nsgr's fix for the "wake up from sleep panic mode" on High Sierra?
    I hope to be sure that it eliminates the panic mode issue on HS before having to buy the Pacifist software that I may not use again. Thanks
     
  6. IKSector macrumors newbie

    IKSector

    Joined:
    Jul 23, 2019
    Location:
    Lagos Nigeria
    #2606

    Hello Nsgr, thanks a million lot for discovering and sharing this fix. I need to ask about your experience so far since you've been running your system with this solution.
    Have you experienced the panic mode again after your system goes into sleep mode and you try to wake it up?
    Please can you share your experience so far?
    Thanks again...
     
  7. mcbeej, Jul 25, 2019
    Last edited: Jul 26, 2019

    mcbeej macrumors member

    Joined:
    Jun 7, 2007
    #2607
    Ok, a weird one.

    Summary - I have a 2011 failed GPU with Sierra, which I used the grub solution for, and works perfectly.

    Investigating upgrading to HS, I created a test partition, installed a clean HS (10.13.6) on it, and used the guide where you remove the X3000 driver and so on. This all worked fine, boots fine, brightness/sleep works etc. Great!

    So, now I'm trying to upgrade my main Sierra system to the same HS for real.

    I followed the exact same HS procedure, but this system won't boot normally (it will boot in safe mode).
    It seems to crash at the point where it's disabling the GPU. I get:
    *** Panic Report ***
    : GPU is not found. PCI config access fails!!!
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.20.13/src/AppleMuxControl/kext/GPUPanic.cpp

    in the problem report.

    I can still boot fine into the clean HS system, so the problem is with the upgraded system. The clean HS does pass that point where the dGPU is disabled.

    So, the dGPU is disabled in Nvram, driver is correctly moved into Extensions-off, everything is the same between both systems, SIP off in both cases.

    Any tips as to what to try, or what might be going on here?

    Edit: OK fixed - I still had the old AMDWakeHandler kext in /Library/Extensions, which is why I missed it - and that was what was causing the problem.
     
  8. John.giannakou macrumors newbie

    John.giannakou

    Joined:
    Jul 26, 2019
    #2608
    I sent my 'MBP 17" late 2011' for repairs and now I am trying to find a way to revert the fix (which has been working good so far) so it can boot with AMD graphics again! Can anyone help? Thanks a lot
     
  9. DoctorJO macrumors newbie

    DoctorJO

    Joined:
    Jul 26, 2019
    #2609
    i have some issue, my can boot only till "?" sign and when i start install MacOS laptop is restarted. All sreen is red or rose lines. When i boot up from USB ArchLinux and wrote nomodeset command he attempt open terminal and then restart again. Any advice how to disable AMD GPU ?

    Thanks ;)
     
  10. jaynaland macrumors newbie

    Joined:
    Oct 23, 2017
    #2610
    Just do the NVRAM reset.
     
  11. jaynaland macrumors newbie

    Joined:
    Oct 23, 2017
    #2611
    You don't have to use ArchLinux. There's a simple way. MikeyN's guide
     
  12. envy23 macrumors newbie

    Joined:
    Jul 27, 2019
    #2612
    Hi,
    Holy smoke, I can start and see the system boot ...
    Now i follow you step

    Or try the simplest - No needed ArchLinux - Only MacOS:


    Now, as soon as i type the 1st line, the screen when blank and gone ...
    I can start fully to gui ( high Sierra with Retina Mid 2012 15"MBP) but this seem buggy.
    I would love to recover back to somewhere stable and leave it there.

    TIA, Tom
     
  13. Reg from France macrumors newbie

    Joined:
    Aug 5, 2008
    #2613
    Hi,
    just post that to say a big thank you to all of you, particularly to AppleMacFinder of course.
    You saved my life... hum... not my life yet by my MBP late 2011 with the EFI fix.
    its not long that I have the pb corrected but so far, everythg is workg great. Again, thx to all of you.
    KR
     
  14. hageir macrumors newbie

    hageir

    Joined:
    Aug 3, 2019
    #2614
    Hello,
    I have a bunch of these MBPs and have done this to all of them.
    One of them runs Lion and is my audio recording computer (no graphics needed anyways)
    I’ve run into this twice now:
    I have a FireWire audio interface and once daisy-chained another one to it and the 15” 2011 MBP panicked and all a I got was a black screen... I remember I left it without the battery for a night and did a couple of SMC and PRAM resets and it finally got back to normal after some procedure I don’t remember!
    Now it’s happened again: black screen of Doom... No dice, just a weak/dim sleep light.

    Does anybody have tips for that?

    (the last time, it also got stuck in a “chime loop” never seen that, it was creepy as hell LOL)
     
  15. 3liminate macrumors newbie

    Joined:
    Apr 21, 2019
    #2615
    Wanted to check if people are using an External monitor/display?
    I saw a comment that says to use a USB to HDMi adapter? Does everything work as normal? Thanks
     
  16. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #2616
    QW
    If you've got a 2011 model you've disabled the AMD GPU on, using the Thunderbolt/MiniDisplay Port as an output will no longer work.

    Since this model also only has USB2, a USB to HDMI adapter also will not work, I don't think.
     
  17. hageir, Aug 10, 2019
    Last edited: Aug 10, 2019

    hageir macrumors newbie

    hageir

    Joined:
    Aug 3, 2019
    #2617
    Anybody run into this? I've tried everything (the last time it worked again, eventually)

    *edit*
    I disconnected the fans, overheated the machine,
    (had previously inserted a CD into the drive, as suggested in another thread)
    after it heated up quite a lot, shut it off, disconnected the battery+power, took out the RAM, let it sit and cool down.
    Connected all above, held in the Eject button and turned it on, BOOM boot chime and question mark (there was no hard disk present)
    Now I need to install a hard disk and do the NVRAM dGPU variable hack again and all is back to normal (running on Intel software GPU)
     
  18. mclindy, Aug 10, 2019
    Last edited: Aug 10, 2019

    mclindy macrumors newbie

    Joined:
    Aug 10, 2019
    Location:
    Portland, OR USA
    #2618
    I have had to "fix" my wife's 2011 15" MBP several times due to updates. Yes, I've since resolved that issue (I hope), but I'm not confident that it won't happen again!

    I have seen and used versions of the script(s) I found here. However, I wanted to consolidate it/them *and* make them EASY for a typical user. I also wanted to make it glitchy screen booting in single user mode friendly.

    So here's what I came up with.

    Somebody better than me (that's most of you!) should vet it. If you don't read code you shouldn't use this until others either confirm/approve or tear it apart/critique. For this reason I'm not going to get into how to set proper permissions on the file. Hopefully that's some kind of firewall to protect users until this is vetted.

    Booting into single user mode then changing to read/write is kind of a big hurdle for a typical user. However, if they can get that point they only have to type ./amdFix.sh (I named mine amdFix.sh) then hit Y,V,Y. This applies the necessary changes then reboots the system.

    Note that it does not create the directory for inactive extensions, nor does it move the AMD kext. Hmm, now that I'm typing it I should probably add some script that checks to see if the new directory exists and if it contains a copy of the AMD kext. If that directory doesn't exist and/or doesn't contain the kext, the script should offer to create the directory and copy the file over before prompting for step 1. This would be risky, though, because I don't know what others might have named that directory! On my system, I named it Extensions-off .

    BTW I realize that sudo is almost certainly redundant here, since in S.U.M. I'm logged in as root. I think I said earlier that I took this/these from scripts that have been posted earlier. I/we could modify this script and remove sudo but what's the harm in a little redundancy?

    At any rate, props and thanks to all of the work everyone has done. I hope this helps the less tech-savvy people resolve this issue.

    For the record, this scrip is working on:
    MacbookPro 8,2
    15 inch, late 2011
    Intel Core i7 2.2 GHZ 4 core
    8 GB RAM
    High Sierra 10.13.6
    Latest OS update: Security Update 2019-003​

    Code:
    #!/bin/bash
    # Compiled from https://forums.macrumors.com/threads/force-2011-macbook-pro-8-2-with-failed-amd-gpu-to-always-use-intel-integrated-gpu-efi-variable-fix.2037591/
    #
    #
    # Clear terminal screen so a user with a bad display has some evidence that script is running
    printf '\ec'
    #
    #
    # Describe step 1 and prompt user to execute
    printf 'Step 1\n * Delete Radeon X3000 kext from /System/Library/Extensions\n * Clear drivers cache\n * Recreate cache directory\n * Update timestamps\n * Change GPU power preferences to Intel graphics\n\n'
    read -n1 -p 'Do step 1? [y/n] ' step1
    case $step1 in
        y|Y)
            sudo rm -rf /System/Library/Extensions/AMDRadeonX3000.kext
            printf '\n\n + Deleted Radeon X3000 kext'
            sudo rm -rf /System/Library/Caches/com.apple.kext.caches
            printf '\n + Driver cache cleared'
            sudo mkdir /System/Library/Caches/com.apple.kext.caches
            printf '\n + Cache directory was created'
            sudo touch /System/Library/Extensions
            printf '\n + Timestamps updated'
            sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00
            printf '\n + Changed GPU power preferences to Intel graphics\n\n';;
        n|N)
            printf '\n\n - Skipped Step 1\n\n';;
        *)
            printf '\n\nInvalid input!\n\n***Aborted***\n\n'
            exit;;
    esac
    #
    #
    # Set boot arguments
    read -n1 -p 'Set boot arguments to verbose [v] or none [n]? [v/n] ' setBootV
    case $setBootV in
        v|V)
            sudo nvram boot-args="-v"
            printf '\n\n + Boot arguments set to verbose with nvram boot-args="-v"\n\n';;
        n|N)
            sudo nvram boot-args=""
            printf '\n\n + Boot arguments set to none with nvram boot-args=""\n\n';;
        *)
            printf '\n\n - Did NOT change boot arguments\n\n';;
    esac
    #
    #
    # Prompt user to reboot now or exit
    read -n1 -p 'Restart now? Y/y = yes, any other key = exit ' rebootExit
    case $rebootExit in
        y|Y)
            printf '\n\n + Restarting...\n\n'
            sudo shutdown -r now
            ;;
        *)
            printf '\n\n - Script ended without rebooting\n\n';;
    esac
    
    When you run it in the terminal it looks like this:

    Step 1
    * Delete Radeon X3000 kext from /System/Library/Extensions
    * Clear drivers cache
    * Recreate cache directory
    * Update timestamps
    * Change GPU power preferences to Intel graphics

    Do step 1? [y/n] y

    + Deleted Radeon X3000 kext
    + Driver cache cleared
    + Cache directory was created
    + Timestamps updated
    + Changed GPU power preferences to Intel graphics

    Set boot arguments to verbose [v] or none [n]? [v/n] v

    + Boot arguments set to verbose with nvram boot-args="-v"

    Restart now? Y/y = yes, any other key = exit y

    + Restarting...




     
  19. macattack600 macrumors member

    Joined:
    Jan 7, 2012
    #2619
    This is a EFI mod to the bios correct?
    Can this be made permanent to withstand a Nvram Pram reset ?
     
  20. mclindy macrumors newbie

    Joined:
    Aug 10, 2019
    Location:
    Portland, OR USA
    #2620
    This is just a script that automates part of what AppleMacFinder and MikeyN provided. I stored a copy in my root directory so that I can quickly and confidently apply their fixes. I haven't added anything to it so it won't withstand resets any better than their suggestions. I bring nothing new to the table. I'm just automating a process that I've had to repeat and I want to make sure that I don't make a typo in the future, etc. It might be helpful to some and worthless to others.
     
  21. macattack600, Aug 11, 2019
    Last edited: Aug 12, 2019

    macattack600 macrumors member

    Joined:
    Jan 7, 2012
    #2621
    No I'm saying the whole process the whole EFI variable fix , is the a way to disable a pram reset in terminal
     
  22. mcbeej, Aug 12, 2019
    Last edited: Aug 12, 2019

    mcbeej macrumors member

    Joined:
    Jun 7, 2007
    #2622
    I'm having occasional kernel panics from sleep wake on this HS system (maybe once or twice a week, it doesn't always happen when waking from sleep). it's definitely dGPU related, from the crashreporter message.

    Are there any procedures for investigate or fix this?

    Edit: I'll try the "pmset -a force gpuswitch 0" in LoginHook to see whether that helps...
    Edit2: It didn't, the very first sleep it crashed on wake.

    *** Panic Report ***
    panic(cpu 0): "GPU Panic: mux-regs 2 0 1 0 0 0 severity 3 WS-ready 1 switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle system-state 1 power-level 20:20 connect-change 0 : UH eHlPH
    : GPU is not found. PCI config access fails!!!
    \n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.20.13/src/AppleMuxControl/kext/GPUPanic.cpp:170
     
  23. McSimon macrumors newbie

    Joined:
    Aug 12, 2019
    Location:
    UK
    #2623
    Hi all, newbie here and scared of any kind of programming. I feel quite lucky that it’s now 2019 and this is only just happening to my MBP. I want to try and avoid putting all this code in. I’ve managed to reboot using a Time Machine backup - can I just carry on and try not to use anything graphics heavy or is the problem progressive and eventually Time Machine backup will also fail to boot?

    If it helps I’ve got a late 2011 15inch MBP running on High Sierra and all I want to do is use Logic and go on YouTube.

    Thanks
     
  24. diggel macrumors newbie

    diggel

    Joined:
    Aug 12, 2019
    #2624
    trying this on a 2011 MBP. installed High Sierra through an iMac first on an external 2,5" HDD; then updated all (on iMac) and placed this updated HDD in MBP2011. did the vram and pram reset; then opt cmd r s. I turn into localhost:/ root

    this won't let me "csrutil disable" and all the other necessary steps. What went wrong (and how to get this MBP fixed)?

    thanks!
     
  25. ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #2625
    I haven't tried it, but have seen USB 2.0 to HDMI adapters.

    Manhattan USB 2.0 to HDMI Adapter, Easily Converts USB Video
     

Share This Page