macOS 10.14 Mojave on Unsupported Macs Thread

Discussion in 'macOS Mojave (10.14)' started by dosdude1, Jun 4, 2018.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. Larsvonhier macrumors 6502

    Larsvonhier

    Joined:
    Aug 21, 2016
    Location:
    Germany, Black Forest
    #1751
    Got my 7,1 booting up Mojave beta 3 - with semi-acceleration only (256MB video RAM recognized, UIKit stuff works, but overall very laggy). Took a couple of boots to get stable, though (rock solid now!).
    Sound and Wifi work, but internal trackpad does not although external USB works?!?
     

    Attached Files:

  2. tsialex macrumors 601

    tsialex

    Joined:
    Jun 13, 2016
    Location:
    Brazil
    #1752
    I had a lot of trouble to do the normal/1st boot too, but just one SafeMode reboot and worked.
     
  3. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1753
    @tsialex My installation only boots to the setup screen. The setup app never opens.
     
  4. tsialex macrumors 601

    tsialex

    Joined:
    Jun 13, 2016
    Location:
    Brazil
    #1754
    Did you pre-installed onto your supported Mac? Did you tried SafeMode?

    I don't know if you have to add USB/GPU kexts to have the keyboard and GPU working, maybe @Larsvonhier could help you there.
     
  5. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1755
    I’m trying safe mode now.
     
  6. Larsvonhier macrumors 6502

    Larsvonhier

    Joined:
    Aug 21, 2016
    Location:
    Germany, Black Forest
    #1756
    I copied a working boot volume from my MB Air 4,1 (with the patches from dosdude1´s tool) over to a shuttle USB drive and replaced the UserEventPlugins on that volume. My 7,1 has a "drowned" keyboard but working trackpad, so I have to connect an external keyboard anyway - but still wonder why the internal trackpad stops functioning after the boot volume selection (but external mouse works). This setup works as mentioned above on the macbook 7,1.
     
  7. ellaosx macrumors newbie

    Joined:
    Jun 4, 2018
    #1757
    Nice if someone figure out which plugin is the culprit in UserEventPlugins folder, instead of copying it all.
     
  8. Aletancredo macrumors member

    Aletancredo

    Joined:
    Jun 8, 2018
    #1758
    Hello, I have a macbook pro late 2011 with intel 13 inch with intel core i7 second generation 3MB monitor. I followed the mojave patch (by dudeos1) and now I am using the Mojave developer beta 3. Everything is working very well except the sound. Could you help me please how to fix it? Thank you very much.
     
  9. Larsvonhier macrumors 6502

    Larsvonhier

    Joined:
    Aug 21, 2016
    Location:
    Germany, Black Forest
    #1759
    go for it! ;-)
    --- Post Merged, Jul 8, 2018 ---
    re-run the patcher from the installer stick (made with dosdude1´s Mojave Patcher tool) and select at least "legacy audio", rebuild cache and reboot - that should enable audio on your machine...
     
  10. Aletancredo macrumors member

    Aletancredo

    Joined:
    Jun 8, 2018
    #1760
    I will do it thanks
     
  11. jackluke macrumors 65816

    jackluke

    Joined:
    Jun 15, 2018
    #1761
    After deep analysis I have found the culprit:

    On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

    There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

    - leave the Mojave's S/L/UserEventPlugins untouched;
    - replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

    Only replacing this plugin you will get no Kernel Panic on C2D.
     
  12. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1762
    Any idea what that plugin does?
     
  13. Aletancredo macrumors member

    Aletancredo

    Joined:
    Jun 8, 2018
    #1763
    Hi now it working. Thank you very much for your assistance.
     
  14. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1764
    @tsialex Can the PlatformSupport.plist file that needs to be replaced on Mojave and the preboot partition be replaced by the same file or are the regular and preboot version different?
    --- Post Merged, Jul 8, 2018 ---
    @dosdude1 I downloaded a copy of the Mojave installer using your patcher app and upon using it to install on a (supported) Mac I see that there is an update available which means that the installer I downloaded was not up to date. Why is that?
     
  15. Larsvonhier macrumors 6502

    Larsvonhier

    Joined:
    Aug 21, 2016
    Location:
    Germany, Black Forest
    #1765
    which version is the update?
    might relate to beta public vs. beta dev channels
     
  16. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1766
    It’s for PB2.
     
  17. Larsvonhier macrumors 6502

    Larsvonhier

    Joined:
    Aug 21, 2016
    Location:
    Germany, Black Forest
    #1767
    so you started with the ´314 build after downloading with the mojave patcher?
     
  18. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1768
    Dammit I didn’t look.

    Edit: The installer app is version 14.0.11 if that helps.
     
  19. Larsvonhier macrumors 6502

    Larsvonhier

    Joined:
    Aug 21, 2016
    Location:
    Germany, Black Forest
    #1769
    So it was already dev beta 2 I´d assume. Anyway, dosdude1 is alerted and will update the tool in any case due to the C2D findings, hopefully ;-)
     
  20. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1770
    I got to the setup app but I had to press the power button at the setup screen to make the setup app appear for some reason.
    --- Post Merged, Jul 8, 2018 ---
    Input devices (trackpad and external mouse) didn’t work though so I’m replacing more KEXTS.
     
  21. TheStork macrumors 6502

    TheStork

    Joined:
    Dec 28, 2008
    #1771
    I have a MP3,1 that has upgraded CPUs (among other items) to dual X5482 which support SSE4.1. It's currently running the latest version of Sierra. (I'll upgrade to High Sierra when the last update is released before Mojave.) Anybody else with a processor upgraded MP3,1 tried Mojave, yet?
     
  22. Loyd-01a macrumors regular

    Joined:
    Oct 10, 2014
    #1772
    Since a solution had been found for C2D thanks to ASentientBot, the best think that you can do now is to be patient and wait for dosdude1 to modify his patcher for C2D (with all kexts nedeed : for mouse, trackpad, WIFI, sound, etc...).

    Great thanks to all for the wunderfull work !
     
  23. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1773
    Yeah I know. Let’s hope that this will be added SOON.
     
  24. dosdude1 thread starter macrumors 68000

    dosdude1

    Joined:
    Feb 16, 2012
    #1774
    It will be, I plan on having a new patcher done by the end of the day today.
     
  25. julianfairfax macrumors 65816

    julianfairfax

    Joined:
    Jun 11, 2018
    Location:
    (UTC+1, UTC+2 during DST) Switzerland
    #1775
    You have got be kidding me. I feel like I’ve just been momentarily transported to heaven.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page