Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
Status
The first post of this thread is a WikiPost and can be edited by anyone with the appropiate permissions. Your edits will be public.

Larsvonhier

macrumors 65816
Aug 21, 2016
1,022
1,757
Germany, Black Forest
Got my 7,1 booting up Mojave beta 3 - with semi-acceleration only (256MB video RAM recognized, UIKit stuff works, but overall very laggy). Took a couple of boots to get stable, though (rock solid now!).
Sound and Wifi work, but internal trackpad does not although external USB works?!?
 

Attachments

  • Bildschirmfoto 2018-07-08 um 12.58.57.png
    Bildschirmfoto 2018-07-08 um 12.58.57.png
    759.9 KB · Views: 523
Comment

tsialex

macrumors G3
Jun 13, 2016
9,427
10,178
Got my 7,1 booting up Mojave beta 3 - with semi-acceleration only (256MB video RAM recognized, UIKit stuff works, but overall very laggy). Took a couple of boots to get stable, though (rock solid now!).
Sound and Wifi work, but internal trackpad does not although external USB works?!?

I had a lot of trouble to do the normal/1st boot too, but just one SafeMode reboot and worked.
 
Comment

Larsvonhier

macrumors 65816
Aug 21, 2016
1,022
1,757
Germany, Black Forest
Did you pre-installed onto your supported Mac? Did you tried SafeMode?

I don't know if you have to add USB/GPU kexts to have the keyboard and GPU working, maybe @Larsvonhier could help you there.
I copied a working boot volume from my MB Air 4,1 (with the patches from dosdude1´s tool) over to a shuttle USB drive and replaced the UserEventPlugins on that volume. My 7,1 has a "drowned" keyboard but working trackpad, so I have to connect an external keyboard anyway - but still wonder why the internal trackpad stops functioning after the boot volume selection (but external mouse works). This setup works as mentioned above on the macbook 7,1.
 
Comment

Aletancredo

macrumors member
Jun 8, 2018
50
27
I feel like I'm so close to getting graphics acceleration working! But I'm kinda stuck. So far, the full list of what I'm replacing is:

/S*/L*/UserEventPlugins <-- Fixes the panic. To do: check which one is the root cause and leave the rest alone

/S*/L*/E*/IOUSBHostFamily.kext <-- Fixes USB, keyboard/touchpad.

/S*/L*/E*/AppleHDA.kext <-- Fixes sound.

Now, I'm replacing:
/S*/L*/E*/GeForceTesla.kext
/S*/L*/E*/GeForceTeslaGLDriver.bundle
/S*/L*/E*/GeForceTeslaVADriver.bundle
/S*/L*/E*/IOGraphicsFamily.kext
/S*/L*/E*/IONDRVSupport.kext
/S*/L*/E*/NVDANV50HalTesla.kext
/S*/L*/E*/NVDAResmanTesla.kext
/S*/L*/E*/NVDAStartup.kext

The computer boots to the login screen which lacks the horrendous graphical glitches without these replacements. Login is way quicker and graphical glitch free. The fade into the desktop is smooth and the menu bar is transparent... but... then it panics. A second or two after reaching the desktop.

Attaching log here. Could some of the more experienced hackers check this one out? It's probably a simple fix. Thank you :)
[doublepost=1531031674][/doublepost]

Got any details on this? I read through this whole thread as it was posted but I don't remember that and don't feel like searching through 68 posts right now ;). I feel like I'm really close.
Hello, I have a macbook pro late 2011 with intel 13 inch with intel core i7 second generation 3MB monitor. I followed the mojave patch (by dudeos1) and now I am using the Mojave developer beta 3. Everything is working very well except the sound. Could you help me please how to fix it? Thank you very much.
 
Comment

Larsvonhier

macrumors 65816
Aug 21, 2016
1,022
1,757
Germany, Black Forest
Nice if someone figure out which plugin is the culprit in UserEventPlugins folder, instead of copying it all.
go for it! ;-)
[doublepost=1531050784][/doublepost]
Hello, I have a macbook pro late 2011 with intel 13 inch with intel core i7 second generation 3MB monitor. I followed the mojave patch (by dudeos1) and now I am using the Mojave developer beta 3. Everything is working very well except the sound. Could you help me please how to fix it? Thank you very much.
re-run the patcher from the installer stick (made with dosdude1´s Mojave Patcher tool) and select at least "legacy audio", rebuild cache and reboot - that should enable audio on your machine...
 
Comment

Aletancredo

macrumors member
Jun 8, 2018
50
27
go for it! ;-)
[doublepost=1531050784][/doublepost]
re-run the patcher from the installer stick (made with dosdude1´s Mojave Patcher tool) and select at least "legacy audio", rebuild cache and reboot - that should enable audio on your machine...
I will do it thanks
 
  • Like
Reactions: ASentientBot
Comment

jackluke

macrumors 68040
Jun 15, 2018
3,308
7,996
Nice if someone figure out which plugin is the culprit in UserEventPlugins folder, instead of copying it all.

After deep analysis I have found the culprit:

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.
 
Comment

0403979

Cancelled
Jun 11, 2018
1,402
1,733
After deep analysis I have found the culprit:

On a Macbook7,1 aka Core 2 duo with penryn architecture Nvidia 320M MCP89 Controller, I suppose this will work on any Penryn c2d Mac too.

There is no need to add and replace all the UserEventPlugins folder instead follow these steps:

- leave the Mojave's S/L/UserEventPlugins untouched;
- replace from a High Sierra's S/L/UserEventPlugins just this plugin: com.apple.telemetry.plugin

Only replacing this plugin you will get no Kernel Panic on C2D.

Any idea what that plugin does?
 
Comment

0403979

Cancelled
Jun 11, 2018
1,402
1,733
@tsialex Can the PlatformSupport.plist file that needs to be replaced on Mojave and the preboot partition be replaced by the same file or are the regular and preboot version different?
[doublepost=1531057205][/doublepost]@dosdude1 I downloaded a copy of the Mojave installer using your patcher app and upon using it to install on a (supported) Mac I see that there is an update available which means that the installer I downloaded was not up to date. Why is that?
 
Comment

Larsvonhier

macrumors 65816
Aug 21, 2016
1,022
1,757
Germany, Black Forest
@tsialex Can the PlatformSupport.plist file that needs to be replaced on Mojave and the preboot partition be replaced by the same file or are the regular and preboot version different?
[doublepost=1531057205][/doublepost]@dosdude1 I downloaded a copy of the Mojave installer using your patcher app and upon using it to install on a (supported) Mac I see that there is an update available which means that the installer I downloaded was not up to date. Why is that?
which version is the update?
might relate to beta public vs. beta dev channels
 
Comment

0403979

Cancelled
Jun 11, 2018
1,402
1,733
So it was already dev beta 2 I´d assume. Anyway, dosdude1 is alerted and will update the tool in any case due to the C2D findings, hopefully ;-)

I got to the setup app but I had to press the power button at the setup screen to make the setup app appear for some reason.
[doublepost=1531058508][/doublepost]
So it was already dev beta 2 I´d assume. Anyway, dosdude1 is alerted and will update the tool in any case due to the C2D findings, hopefully ;-)

Input devices (trackpad and external mouse) didn’t work though so I’m replacing more KEXTS.
 
Comment

TheStork

macrumors 6502
Dec 28, 2008
284
175
I have a MP3,1 that has upgraded CPUs (among other items) to dual X5482 which support SSE4.1. It's currently running the latest version of Sierra. (I'll upgrade to High Sierra when the last update is released before Mojave.) Anybody else with a processor upgraded MP3,1 tried Mojave, yet?
 
Comment

Loyd-01a

macrumors regular
Oct 10, 2014
116
122
I got to the setup app but I had to press the power button at the setup screen to make the setup app appear for some reason.
[doublepost=1531058508][/doublepost]

Input devices (trackpad and external mouse) didn’t work though so I’m replacing more KEXTS.
Since a solution had been found for C2D thanks to ASentientBot, the best think that you can do now is to be patient and wait for dosdude1 to modify his patcher for C2D (with all kexts nedeed : for mouse, trackpad, WIFI, sound, etc...).

Great thanks to all for the wunderfull work !
 
Comment

0403979

Cancelled
Jun 11, 2018
1,402
1,733
Since a solution had been found for C2D thanks to ASentientBot, the best think that you can do now is to be patient and wait for dosdude1 to modify his patcher for C2D (with all kexts nedeed : for mouse, trackpad, WIFI, sound, etc...).

Great thanks to all for the wunderfull work !

Yeah I know. Let’s hope that this will be added SOON.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.