Watch not connecting airpods to radio

Discussion in 'Apple Watch' started by PavelT, Jan 25, 2018.

  1. PavelT macrumors regular

    Joined:
    Nov 12, 2012
    #1
    hey guys,

    im having a problem with my airpods and watch series 3 LTE....

    my watch does not connect my airpods when i put on the radio.
    when i put on radio, it displays the page where it asks me what audio source i want to use. i click on my airpods. and the loading ticker displays and then comes back an error that says ["Connection failed. Make sure "person's airpods" is turned on and in range."].. and of course they are on, as im receiving calls, and making calls from the watch. this happens on wifi and cellular. i have reset my airpods, forgot my airpods, and have reset and unpaired my watch. and i still get this error. so my audio apps (radio,podcast,music) are rendered useless, as this happens 90% of the time...but my airpods seem to work with radio on my iphone without problem.

    anyone else having this problem?
     
  2. MajorBulldog macrumors newbie

    Joined:
    Sep 23, 2017
    #2
    I've had the same problem off and on. Sometimes they connect instantly and other times they will not connect at all. I believe this is a software bug on the watch and not the AirPods. The AirPods always connect to my iPhone without issue. The problem may be related to handoff between the iPhone and the watch. If the phone is still within range, the iPhone seems to win (at least until the WatchOS update this week) until the watch is rebooted.

    When the watch and AirPods starting having trouble, I power-cycle the watch instead of unpairing AirPods. Once the watch powers back on (effectively rebooting it), the AirPods connect without issue.

    The latest update may have improved the situation. I say may because the improvement I saw could simply be a result of the watch rebooting after the update. We'll see what happens when I go for a long run in the morning.
     
  3. MajorBulldog macrumors newbie

    Joined:
    Sep 23, 2017
    #3
    Well, after the last WatchOS update, the Radio app seems to be completely broken for use with AirPods. Other watch apps that use the AirPods (Music, Siri, etc) work just fine. Settings > Bluetooth shows that the AirPods are connected, but for some reason, the Radio thinks they aren't connected, tries to connect, and then fails. Power-cycling the watch does not resolve the issue in this case.

    Anyone else seeing this? This just started happening this week after I applied the latest update (...the one that seemed mostly targeted at fixing the character bug).
     
  4. hankdatank! macrumors newbie

    hankdatank!

    Joined:
    Mar 6, 2018
    #4
    --- Post Merged, Mar 6, 2018 ---
    I have the exact issue... what I did find is - I can play the locally stored music on my watch using Music... as soon as I try to stream radio or ask Siri to play x, i am unable to
     
  5. MajorBulldog macrumors newbie

    Joined:
    Sep 23, 2017
    #5
    I've gone back to power-cycling the watch to get it to recover. The first time I tried this, it didn't work as I reported above. I tried the power cycle trick again the next day and the Radio app began to work with the AirPods. That was yesterday. Its still working today (...just tried it).
     

Share This Page

4 January 25, 2018